Audiobook Problems Again!

I posted awhile back that audiobooks were not downloading correctly into the player. I was pleased to report that the problem was resolved. Well, I started to download some things into my mother’s player and the same thing happened. It downloaded one book perfectly from the Overdrive Media Console (what many libraries use as their download center) and I was thrilled. Then I downloaded another and BINGO it started to go strange! Part 2 of the book appears at the top of the list and Part 1 is at the bottom of the list under the last Part. As a result it won’t correctly play. I tried several books and same thing happened. I contacted the library media center and they are investigating it and I also contacted SanDisk. It appeared this tech person wasn’t too sure of himself as he kept excusing himself to talk to people. He finally determined that my firmware was old. Pretty good I just purchased it a few weeks ago, tells you where this has been! He was to send me the information in 20 minutes with instructions. He never did, so I went and downloaded the current version. Bottomline it didn’t correct it. I am calling again tomorrow. My next thing is to reformat it as I did with my other, but then I will have to reload everything.

Is anyone else experiencing these issues? I hope this time I have clearly explained myself, if not ask and I will give it another shot.

This was a gift to  my Mom to make things easier for her as CD’s skip and tapes break! The last thing I want is more frustration for her. She has already shown an attitude about it given this problem.

Feedback would be greatly appreciated!

The Fuze is reading the track numbers that were included in the Audiobook files. And the Fuze starts with the first digit. So if the audiobook’s track numbers go 1, 2, 3…11, 12, 13 it will play 1, 11, 12, 13, etc., before it plays 2 and 3.  The track numbers need to be 01, 02, 03. And the human somewhere in the food chain who numbered them didn’t use the zeroes. 

Your easiest solution is to get the free mp3tag and renumber the tracks.  Install it, and allow it to add itself to context menus while installing it (an option pops up). The find the audiobook, right-click on it, and mp3tag will be among the Open With choices. Choose it, highlight all the tracks, make sure they are in the correct order top to bottom, and click on Tools to see Auto-Numbering Wizard. There’s a choice for Leading Zeros. Choose it, run it and your tracks will be properly numbered .

I just wanted to add I have had bad downloads from Overdrive before, both in ID3 tags and incomplete files.  I always do a “sanity check” of track numbers and file sizes on my laptop before transferring the files to my MP3 player.  Let me know if you don’t know how to check on a PC.  If one track is considerably smaller than the rest or the tags are bad, redownloading has always fixed it.  I haven’t run across a book in Overdrive yet that wasn’t properly tagged IF it downloaded properly, but it’s possible there are some poorly tagged books up there. (I just have unreliable internet access, so I get bad downloads.)

In agreement with Black-Rectangle, if tags are bad, I just use MP3Tag instead of redownloading.  With my internet, it’s more reliable than redownloading.

Thank you all for the responses. Appreciate the support. I have to admit I was disappointed with the SanDisk tech support. Since I am new with all this player stuff it is a lot to digest. No I don’t know the “Sanity check” that is a new one to me. I did experiment awhile back with the tags, but at that moment having worked for so many hours to correct the problem I was just too tired too digest any more. It was just was so much nicer when things worked correctly.

There is one question that really confuses me. We now have 2 identical players and everything is exactly the same, same settings, same firmware etc. I downloaded a book for Mom into hers and the order was incorrect. I then downloaded the same into mine to see if it was the book and it went in perfectly! The only difference I can think is that the tech guy had me reformat mine when it went bonkers the first time. Could that be it?

All I keep getting told by all the tech support is that I am downloading it into the player list and it is getting a bit insulting.

Thanks again to all!

Reformatting can help, for reasons undetermined, but you will have to put back all the files you formatted away.

When you say you downloaded the book onto mom’s Fuze–did you go back through Overdrive and her computer? Or did you copy the same files that are on your unit? 

Are you sure Settings/System Settings/USB Mode is exactly the same?  Does she have the same version of Windows Media Player installed that you have? 

Sorry, should have said this, but my Mom lives with me.  I am downloading from the same computer. All her settings on her player are the same as mine. That’s what is so confusing. I understand about the reformatting and that’s one reason I didn’t do it.

Hope this information helps.

You might as well try reformatting. It can’t hurt. Just copy everything from the unit onto your computer or a hard drive first.

Well, I went ahead and reformatted it. It is now working again as it should. Understand I am thankful, but wondering if this is going to be a common thing to often have to do. Any clues as to why this happens?


Thanks again! 

Frankly, no idea. If there was a corrupt file causing problems, formatting removed it. If there was junk left behind from Overdrive audiobooks, like digital-rights information, formatting also removed that. Since you now have the newest firmware, maybe it will be more robust.

There are two other suggestions if the problem recurs but you think formatting is too drastic.

You can delete the database: the index that lists the tracks from the ID3 tags. It’s mtable.sys in the root directory (the driveletter) of the Fuze. When you disconnect, the index will be rebuilt from scratch, which could clean up accreted errors. 

Another is Error-Checking: Connect the unit in MSC mode, right-click, Properties/Tools/Error-checking. That can find corrupt files, but usually corrupt files stop the whole unit from getting fully started–they don’t cause listing errors. 

But you may end up re-formatting again. I’ve had my Fuze since 2008, and had to re-format it exactly once, when I tried switching modes to MTP and Windows Media Player did something strange to the card slot. Other people have had to re-format more often. It really depends on what kind of files you are moving back and forth, how good the tags are, and whether there is sunspot activity on Alpha Centauri. 

Message Edited by Black-Rectangle on 05-09-2010 04:30 PM

Well, speak of the devil. My second reformat. The Fuze stalled at Refreshing Database with my 16GB card inserted. Took the card out, everything was OK. Luckily the computer could access both internal memory and the card.

So I deleted mtable.sys, Error-Checked both internal and external memory, took off the last half-dozen albums added to the 16GB card (in case there were tag problems). Reinstalled firmware. Still stalling. 

Finally, I took out the 16GB card, made sure I had all the copies of the albums in internal memory and Formatted the Fuze from the command in Settings/System Settings.   Bingo. It reads the 16GB card just fine now. Which is a relief, because the card is nearly full and I didn’t want to take the time saving a copy of all the tunes on it. 

So even if you think the problem is the card, even if you’ve just installed bright shiny new firmware, formatting might still be what you need.  Don’t ask me why.