Audiobook File Order

How exactly does the Jam order files in the Book folder?

I have my audiobook files in separate “disc” files, each is the length of a full cd and there are as many cds as the book is long.

The file names are “Disc 01 - Whatever Book”, the track title is also “Disc 01 - Whatever Book” and the track numbers are filled in.

The Jam order them in something seemingly random, for example one book came out as: 06, 01, 07, 02, 08, 10, 04, 11, 05, 03, 09. 

This kind of makes the use of audiobooks difficult…

On a side note the track skip button still works in the audiobook folder (it didn’t on the Clip +, it just fast forwarded if you held it). Why the hell would I want to skip to the next file in an audiobook?

So is this thing pointless for audiobooks?

These files are all 64kbps mp3, by the way.

2 Likes

I have tried everything: renaming files and titles in order of use, making m3u file lists etc., but nothing works. It all ends up with files in seemingly random order. Sometimes only after I have added some more files to the mp3 player. Did they test it before putting it on the market? See:

http://kb.sandisk.com/app/answers/detail/a_id/14337/kw/audiobook%20jam%20clip/session/L3RpbWUvMTQ0NDIxOTUwNi9zaWQvdHh6dGJseW0%3D

http://kb.sandisk.com/app/answers/detail/a_id/8369/kw/audiobook/session/L3RpbWUvMTQ0NDIxOTUwNi9zaWQvdHh6dGJseW0%3D

The only way is not to play the books from “Books”, but to go to “Folder” and walk through the directory tree until you find the files you want to play.

A disadvantage is that you cannot change play speed and the file position is lost after you plug the mp3 player into the computer.

I am having the same problem. I am on firmware v 1.03 and no matter what I do the audiobooks are out of order. I have the correct track #, the titles are all in order, and the filenames are good.

Here is what it looks like in folder view IMG_20160221_173256.jpg

Here is what is looks like in the audio book menu

IMG_20160221_173323.jpg

Here is how my files are tagged

mp3.jpg

Looks like your 3 images were deleted by the SanDisk forum software.

Do you want to try showing us text versions of your audiobook filenames and ID3 tag information?

1 Like

Maybe these will work better

http://s13.postimg.org/w7vr6vf6f/IMG_20160221_173256.jpg
http://s13.postimg.org/zdgcx2xsn/IMG_20160221_173323.jpg
http://s13.postimg.org/captxwwbb/mp3.jpg

Hello ryanmc,

Your image “mp3.jpg” reveals a useful amount of information for some SanDisk Forum members to try and provide assistance.

I think you need to focus on providing specific information within the first 12 characters in the “Titles” tag field.

     For example:  Chapt 01-T01     Chapt 01-T02     Chapt 01-T03

     For your track # tag field, use 2-digit numbers (not 001, etc)

Your image does not reveal information in your “Album” field. Seems like you could use this field to help order your listening sequence if you will have many Harry Potter audio books on your player at the same time

     For example:  04 Goblet of Fire for all the audio files in the image you shared here.

Hopefully these fussy details are not too cumbersome for you. Once you arrive at a personalized solution, you will enjoy using the many convenient features of the Clip Jam.

[The Clip Sport functions in a similar manner to  the Clip Jam]

  1. Does the clip jam not support 100+ files in a directory. is that why you recommend only 2 digits? I use 3 digits 001, 002, etc because there are over 100 tracks and 2 digits would not work.
  2. I have long titles, because on all my other devices it shows the title while playing, and I like seeing the full title, also I upload these to google music to play on my computer and phone, so I don’t want to change the title. Even with ‘Chatper 01’ that is 10 characters and if the clip jam was using title for sorting, then Chapter 01 should show up before Chapter 22, or Chapter 31, but as you can see from the first image that is not happening.
  3. Can you tell me what tag the clip jam uses to sort the tracks? Then, rather than messing up all my tags, I can just focus on one.

Also if you have a list of file limits, or directory limits that would be useful to have as well, rather than always guessing. This is 2016, your software should be able to handle large names and large numbers of files.

Try eliminating the word “Chapter” and just use the numbers (01, 01, etc.) Also your MP3Tag screen shot does not show what the format of the tags are. They should be ID3v2.3 ISO 8859-1.

I have the same problem.

I formatted my clip jam using the clip jam options/settings menu.

I am using IDv3.2 tags.

I entered single-digit track numbers for all tracks.

My track titles start with numbers, and are numbered in the order I want to play them. (This is redundant with track number, but I’ll do anything to get my audiobooks to play in order.)

I individually copy each audiobook to the clip jam, one at a time, in the order I want them played.

None of this helps. The Clip Jam stubbornly refuses to play my audiobooks in proper order. They’re always shuffled.

What happened over at SanDisk? My Clip+ always played my audiobooks in the proper order. Why is the Clip Jam such a huge step backward in functionality?

  1. You should use leading zeros (01, 02, 03 or 001, 002, 003, etc.) & not single digit numbers.

  2. The Jam & Sport models use a different (and less powerful) processor than previous players as it is not made by SanDisk and was discontinued by the manufacturer. They got the only one that was feasibly (& economically) possible. Hence these models work differently and some features are no longer available.

I tried using chapter #s with leading zeroes (01, 02, 03, etc…) but still no joy.

Maybe provide a few examples of the folder names, file names and ID3 tag data you are using?

Make sure you are using ID3v2.3 ISO-8859-1.

Actually, now that you mention file names, my chapter titles are the same for the first 18 characters. The track titles start with numbering, but not the filenames.

I’ll try adding a numbering order to the front of the filenames and see if that helps.

Your suggestion for revising your filenames (01, 02 etc) will hopefully work when you are using FOLDER MODE.

Also, maybe take a quick look at this web-page.

     http://www.techsupportalert.com/content/sort-files-alphabetically-usb-stick-or-mp3-player.htm

If you similarly revise your Track Titles in your ID3 tags, then ordered playback will hopefully work when you are using BOOK MODE.

Folder mode won’t work for books, though, right? It won’t preserve my place I don’t think.

However, that directory sorter looks like a winner. Thinking back, I definitely recall the command DirSort (or was it SortDir?) from my DOS days in the late 80s/early 90s. Since that was the same FAT system, this could very well be the solution I’ve been looking for.

I’ll give it a shot the next time I copy audiobooks to my player (later this week, mostly podcasts) and post back here with the results.

Thanks much, this could actually work.

Just completed some quick testing of your questions.

FOLDER MODE

         The FAT sorter program will enable sequential display of files using ClipSport (and Jam).

         ClipSport (and Jam) will not create a “Resume File” for mp3 files in the AUDIOBOOKS folders.

AUDIOBOOKS MODE

        The FAT sorter program will have no effect on the display of files using ClipSport (and Jam).

             The sequential display of files depends on the first 12 characters in the Titles and Albums fields in the ID3 tags.

         ClipSport (and Jam) will create one “Resume File” for each mp3 file in the AUDIOBOOKS folders.

Thanks much for testing that.

Renaming the filenames themselves to start with a 2-digit number doesn’t help.

Copying the files one at a time in proper order (to ensure FAT order is correct) doesn’t help.

The ID3v2.3 titles start with a 5-digit date (eg: 03-16) in proper order, but that doesn’t help.

Track numbers have 2-digits (eg: 01, 02, 03…) but that doesn’t help.

No matter what I do, Clip Jam consistently plays (and shows) my tracks in random order.

Should I remove the track numbers?

Your comments about problems with audiobook playback order seem to relate to ID3 tagging problems using BOOK MODE.

        Filename ordering problems (and FAT table sequencing) applies only to FOLDER MODE.

Maybe it is hard to provide best advice without seeing examples of your ID3 tags??  

Maybe you could post here one example of your data entries for all the ID3 fields in one of your audiobook files?

I have never tried using 5-digit dates in the audio title field of my ID3 tags.  I typically use 2-digit prefixes (followed by a space or a hyphen) then text labels of 8 or more letters in the audio title field. The first 8 letters of the text labels should readily indicate the specific title of the audio file (not the artist name, etc).   Seems like you have proven that 2-digit track numbers do not solve your situation.  Maybe you can try using helpful data in the Album Title field in your ID3 tags.

        And maybe you have discovered that BOOK MODE ignores your physical layout of subfolders in your AudioBook folder. Your subfolder layout can be used to help you properly manage your files on your player.

I can tell you that it really is possible to get this all to work in BOOK MODE with the correct combination of data entries in the ID3 tags.  Once you have a working set of files you will hopefully start to enjoy using this handy little audio player.

The complete ID3v2.3 tag info for the three audiobooks currently on my player right now:

Title: 03-14 Monday

Track: 01

Artist: Podcast name

Allbum: Podcast name show

Year: 2012

Genre: Comedy

Title: 03-15 Tuesday

Track: 02

Artist: Podcast name

Allbum: Podcast name show

Year: 2012

Genre: Comedy

Title: 03-16 Wednesday

Track: 03

Artist: Podcast name

Allbum: Podcast name show

Year: 2012

Genre: Comedy

All other ID3v2.3 tag fields are blank. The year is set at 2012 because I don’t bother to update it. The “Podcast name” and “Podcast name show” are the same for all files. (It’s the same show, different days.)

EDIT: And as mentioned, these three audiobooks are displayed and played in random order.

The pattern below is a kind of “trial starter” series to test. If it works then you can expand on it and be the new Podcast Guru here.  Play using BOOKS MODE (Not Folder Mode).  Please write back here soon with your results.

    Hopefully more Sansa regulars will make better suggestions.

Title: 14-Monday

Track: 

Artist: Podcast name

Album: 03-Podcast name show

Year: 2012

Genre: Comedy

Title: 15-Tuesday

Track: 

Artist: Podcast name

Album: 03-Podcast name show

Year: 2012

Genre: Comedy

Title: 16-Wednesday

Track: 

Artist: Podcast name

Album: 03-Podcast name show

Year: 2012

Genre: Comedy