Audiobook chapters are listed in order but heard in random instead of sequential

I downloaded a book from NH Downloadable books, it appears in Audiobooks, the chapters are listed in proper order yet they play in random order. They jump around. How do I fix this?

If those are New Hampshire Downloadable Audiobooks (that’s what Google gave me for NH downloadable) they are in .wma or .mp3 format. The Fuze finds their order by looking at their tags–data included with the file–and looking for Track Number. If that field is empty or wrong, they will play in the wrong order.

Also, if the track numbers are in the style 1/20, 2/20, etc. the Sansa is not too bright: it ony reads the first digit, so it will play 1/20, 11/20, 2/20,  20/20. 

So fix them. 

This FAQ:

http://forums.sandisk.com/sansa/board/message?board.id=announcements&thread.id=201&view=by_date_ascending&page=1

has info about ID3 tags.

Download mp3tag, as linked in the FAQ,  and when you install it allow itself to add itself to Context Menus. Set it to Write ID3v2.3 ISO-8859-1, the Sansa’s favorite tags, as explained in the FAQ. 

Now find an audiobook folder and right-click on it. mp3tag should be among the choices. Click on that and highlight all the files in mp3tag. Make sure they’re in the right order and go to Tools/Auto-numbering Wizard and pick the Leading Zeros option. (That makes sure the tracks are 01,02… instead of 1/20, 2/20…)  Now they should play in the right order.

I know this sounds a little complicated. But once mp3tag is installed and you’ve set the default, it’s just 5 clicks:  mp3tag, highlight all, Tools,  Auto-numbering, Leading Zeros. All told, about 10 seconds per audiobook.

Hi, Black - Your link is not active.  So I copy/pasted into an address line and got 97 responses via Google.

Could someone post a valid link to the actual thread?

I’ve been ripping audiobooks on my Linux PC and hand-editing the track numbers.  If I can copy the rips over to a Windows PC and use mp3tag that would save some time!

FAQ

mp3tag

My adblocker was fighting the link popup. However, if you had cut-and-pasted both lines it would have gone right to the link. Happy trails. 

I believe there’s tagging software called Easytag for Linux. But be extra careful about what format (ID3v2.3 ISO-8859-1) it writes the tags in. (Not Unicode, UTF-8 or UTF-16.) Some people have had trouble with Easytag tags. 

Smooth as a gravy sandwich!  Use MP3Tag and the Auto-Numbering Wizard for your audiobooks, then transfer them to the Fuze.

Bob  :smileyvery-happy:

Don’t forget to use the Leading Zeros option for Auto-Numbering.