Audible book download blew out my Sansa!!!


I don’t get it. This Sansa express worked perfectly before I downloaded my free audiobook from Now it’s completely dead.  Doesn’t make sense but I’m returning it with no arguement to Anyone else experienced this sudden failure? It blew when I tried to sync with the enclosed audible manager. I’m getting nothing but the Sansa logo momentarily when I turn it on, then it goes black. When I plug into the USB port it lights up a couple of blue pixels and that’s it. So much for Audible audiobooks.


Well, Joe, your the 2nd person on my list to assist today… all because i am bored at work!

Some people state that they try the soft/hard reset of the device by pressing and holding the volume UP button and the center gray square at the same time for 30 seconds.  then they turn it on and it works, other say after the 30 sec, they connect to the pc and it works.

thats much quicker than returning the player!

Thank you but I did try the factory reset and I could not get the device to reset. I didn’t time it to exactly 30 secs but I was certainly close and the device was still unresponsive. seemed very coincidental with the audiobook. Also, The main menu had no selection for audiobook or anything similar. I didn’t know where to find my audio book on the device.

it was mentioned in a different thread that somebody put a microSD card into the sansa and it turned on… if you have one try that!

otherwise, you would have to contact support or something