Anybody have luck with data recovery company? 64gb micro sdxc

I have a sandisk 64gb mini sdxc card that i used to record our vacation video using a gopro 3 black edition camera.

The memory card failed,camera says no sd and when i plug into my desktop computer it does not recognize card

I am considering sending card to data recovery company to try to recover video,has anybody had any luck doing this?

I recently had the same problem with my GoPro Hero3 Black Edition.  I was recording vacation videos on my SanDisk Ultra 64GB Micro SDXC.  I’ve recorded a few on this card prior to this vacation without a problem.  When I hooked up the GoPro to my computer to transfer the images, the GoPro locked up as it was connecting.  I had to remove the battery from the GoPro and when it turned back on, the GoPro says “No SD”.  I’ve tried a few recovery software options, but nothing has worked.  When I plug this card into my system, it says the card is not formatted.  If I select the option to format it, it only sees 30.6MB out of the 64GB it should have.


exactly the same thing here. it seems to be a fairly common problem…next memory card will be kingston, does not seem to have the problems like sandisk cards have.

So dissapointing

dear i found the solution to this problem, it is written on GOPRO site, 

normal windows will not read exFAT format which comes with the 64GB, so you will have to update the file formate system on windows site and it will work without even formatting your card.

try this link

I have other sd cards with exfat file system and my computer has no issues with them… The camera was working fine and recording video when it stopped working and put the message on the cameras screen “no sd” I put a different card with same format and size and the camera sees that one fine , the problem is with the mem card

If you are finding difficulty in reading data from Sandisk it might be that your card is corrupted and you are unable to access data from it.  Use Sandisk recovery software  to get back all your data stored in sandisk. It even restores the accidentally deleted files and when scanning process get overs, the Sandisk recovery software safely restores the file in a desired location.

It sounds like your SanDisk card is seriously corrupted. And it is also really difficult to restore all stored data back from a corrupted memory card. But, I have ever successfully restored my wanted data back from a dropped memory card by reading this article:

You may also get some clues there.

Note: Never save all important data on only one drive or memory card in the future.

My brother has ever successfully restored his camera card data back with the help of data recovery tool:

Right now, I still remember its four useful data recovery modes.

Therefore, this tool may also help you.

PS: In case of similar data recovery problems, you should always copy all card data on different drives or locations timely.

Here is a video tutorial that can help you rescue your card data step by step:

It could help you somehow. 

I had exactly the same issue and was streaming my GP3 Black Edition to my iPad watching me taking the kids paragliding off the back of a boat.  It was awesome.  The streaming stopped and then the neither the GP3 or my computer would read the SanDisk.  Just says No SD.  I desperately want to recover the lost footage of that experience and also of other things.  Did you have any luck?  It appears to have happened to a lot of people and I am ropable.

I had the same problem with my GoPRO Hero 2 and an exFAT formatted SD card. I downloaded MaxDataGenius from and it recovered fully with the so called “Formatted Scan”.

This thread is quite old- but maybe it helps…