Album Art - None Displayed

I have the latest f/w 2.36.03A, but ever since 1.32 I have not been able to get Album Art to display. I have tried all the usual tricks.

I have no problem seeing album art on my older Fuze using the same setup, and I was able to see album art prior to 1.32 f/w on the Fuze+.

I have tried MSC, MTP, etc. The album art is embedded in the tags, and if I copy an MP3 from the Fuze+ back to my PC, I can see and display the embedded art. So, I know it’s there.

I use Winamp to load my Fuze+, but it cannot be a Winamp issue, as it works fine with the older Fuze (same setups).

Anybody else notice this? Maybe the younger crowd doesn’t care about album art. I am ripping all my own CDs, no downloads, rhapsody, iTunes, etc.

On my PC, there is a jpg in each album folder with the art (downloaded from Gracenote), as well as the embedded tag art. I have tried Autofill from Winamp copying individual tracks, and “Copy Complete Albums”  - no change.

Thanks in advance to any Fuze+ gurus.

@brush wrote:

I have tried all the usual tricks.

Perhaps you could tell us more about these “usual tricks”. I assume that you’ve tried retagging them with MP3 Tag? Perhaps you’ve tried renaming the jpgs in the folder to “folder.jpg” (as opposed to something else like “album art.jpg”, which works on the older Fuze, but not the Fuze+). Or, have you tried opening them and re-saving them with some kind of photo editor (IDK why this works but it sometimes does)?

  1. jpeg files are “same_name_as_album.jpg”. not “album_art.jpg” or “folder.jpg”.

  2. Naming as used in 1. above always worked on my Sansa View , my Sansa Fuze , and previously this Sansa Fuze+

  3. I feel I should not have to manipulate all of my data when I replace my player, or even just update the f/w. Especially when it is approaching 700 albums and 10,000 tracks.

  4. Having already spent more than enough time nursing this player, I’ll just stick to installing the latest f/w when available.

At least the lock function works now, but it still has a hyper-sensitive touchpad, and an on/off button that sometimes wants to work as a beginning-of-track/next track button. Oh, and the volume controls that often don’t work at all in Lock mode, no matter how long I wait. And I’ve given up on ever using an SD card - way too long to load.

I had the same issue. Resolved it by doing the following [note: issue is caused by hidden artwork files in my case - the Fuze+ seems to corresponding hide the files???, result of using windows media player/media center + media monkey previously and letting them get artwork; cleaning up the mess is all that is needed]:

  1. Create folder on PC for files I am going to copy to the Fuze.

  2. Copy the music folders to this folder - each folder is for an album and contains a variety of artwork including a jpg that I have already added and know is the correct artwork.

  3. Use windows search to find all of the albumart*.jpg files. Note: these are hidden and you will need to turn on viewing hidden files and folders. I delete all of these.

  4. Next remove the hidden and system attributes from any of the remaining jpgs - Do a Shift+Right click on the folder containing the MP3 folders and select “Open a command prompt here”. Type in Attrib *.* -s -h /s Press Enter. Type in Exit and press enter.

  5. Copy the MP3 folders to your Fuze with windows explorer.

Unfortunately, none of this seems to apply to my problem:

  1. No hidden files in any of the folders;

  2. No hidden or system attributes;

  3. Same music to an older Fuze works just fine (in MTP mode).

What’s more confusing is that a 2-disc album, in two folders under same Artist, using the same JPG file as the Artwork in the Tag, will display the Art for one disc, but not the other.

And it’s not related to whether a file has Comments or not as mentioned by another poster.

And itt’s not related to whether the JPG is perfectly square (eg. 300x300), or whether it is 200, 300, 400 pixels in dimensions, as also previously mentioned.

Your power button should not be redirecting to other functions.  Be sure that the latest firmware is installed, it solves two issues: the LOCK button is retasked to the power button, and the latest version solves the irritating "dead volume controls when locked’ issue.

I have used embedded art and separate “album art.jpg” and “folder.jpg” successfully.  I’m spoiled, as I use either Windows Media Player or Rhapsody to write the files in MTP mode, where there’s a separate “album” folder with art.  This is one of the little things that MTP automation provides.

It shouldn’t be a problem to manually use MSC mode, though, since I’ve transferred several podcasts and added art while being plugged in using MSC (at the time, restarting a comm session in the other mode wasn’t worth the hassle, I just had to rethink my methods a bit).

Personally, I’d install the latest firmware, and then start anew with a freshly-formatted device.  You shouldn’t be experiencing odd control responses.  The main issue I note is that the volume buttons were problematic.

A brief footnote- I have a Fuze+ with a little quirk, the Power button is a wee bit sensitive, due to the position of the internal PCB.  It’s well within tolerance, but a soft “tap” of the device against my trusty cushion, a neoprene mouse pad, makes a notable improvement, as the button’s travel improves ever so slightly.  With the Fuze+ aligned vertically, I tap the bottom (headphone connector edge).  It’s the only one I’ve seen with this issue, but it’s always operated fine.

Be sure to have backups of your music, in case of disaster.

Speaking of disasters, I had the opposite, a crashed computer following my daughter’s sortie into some gaming sites.  She didn’t let Daddy know about the “firewall OFF” flag that had been up for 24 hours prior to the crash.  I used the Sansa in reverse, reloading the music library from flash memory.

Let me know of your progress, and if the album art resumes normal operation.

Bob  :stuck_out_tongue: