After 4-18-18 update menuing system is cattywampus.


I have a Sandisk Clip Sport MP3 player & I just updated it 4-18-18 as the menuing system didnt work…  Loaded my MP# files back in, menus worked, however after the update the 6000 mp3 files appeared in an odd order no matter whether I selected: shuffle, artists, albums, etc.

Before update I was able to select folder, view & play all songs in the folder, very smart & easy.  Now I can’t duplicate the same process, configuration.  No matter what I select, everything I get is cattywampus.

Any ideas, suggestions?



This is what I had before up date:

sandisk songs.png

Are you using FolderMode to play your music files?  Maybe take a look at the information in this recent discussion in this Forum.

Also, are you aware that all the player Firmwares released since Dec. 2015 only allow for cataloging up to 2000 music files in each Music database.??

Dear DFELD2005,

Thanks very much for the valuable advice.  I’m including more detailed info to hopefully answer your suggestions.

  1. Purchased Sandisk Clip Sport MP3 player, S/N: B11443CMSK-8GB,  Fall 2011 Approx.

  2. The player has 6.31 GB, 1245 files, 45 folders & peformed flawlessly since several days ago. Did not do any upgrades in that timeframe & was not aware of upgrades.

  3. Tried to use 3 or 3 days ago, chargd player, went to access folders containing MP3’s but was not able to access folders as display was frozed in the FM mode.  Did some simple troubleshooting to no avail.

  4. Went to Sandisk website & found update, downloaded & installed. After waiting for finish, tried to access folders, still ran into problems, catiwampus output. NOTE error popup below.

  5. FM worked conected to preamp as before, no MP3’s worked, moved all MP3’s off player to HD, now player was naked.

Reloaded orig MP3’s, tried to access player: NOTE error popup below.

  1. Files were catywampus but I was able to play the MP3’s but were all fragmented in order.

  2. Your post was the first time I heard of FolderMode.  Don’t have orig instructions.



I hope a few experienced users will reply and provide better assistance for you.

I think the SanDisk Clip Sport was first available for sale in Feb. 2014 (not 2011).

The type of problem you describe can many times be resolved by applying the correct, most recent version of the Firmware for the specific player. (It is critical to not apply the Firmware from a different player.)

Here is a link to the current Firmware (FW 1.39) for the Clip Sport with installation instructions.

Your comment about files playing in fragmented order makes me think you may have some problems with the ID3 tags in your mp3 files.  I use the software “mp3tag” to manage my mp3 files.

Here is a link to the user manual for the Clip Sport.


Ran FAT Sorter as recommeded by DFELD2005 worked. Was able to see folders with indicated sogs inside; Even with the volume turned to max, there was not enough gain to drive my pre-amp.  A few mo ago before this problem surfaced, vol turned up 1/2 way gave proper gain. Nothing else changed.

Thought maybe the Clip Sport was bad? Time for a new one?

Will do a little troubleshooting one my preamp’s input specs.

I don’t supose expect anyone on thisi forum knows the “volume” electrical output specs of the Clip Cport?



Maybe try resetting the player region to North America.

Then try Settings -> System Settings -> Volume -> Normal