A bug that can cause a deadlock

While installing the new firmware I ran into serious problem.

I always use MSC mode and my PC doesn’t have the needed WMP version for using MTP mode. I upgraded the firmware several times in the past always remembering to change the USB setup to MSC mode (It changes to Auto when you upgrade the firmware)

Yesterday after installing the new firmware I used the clip for a while and connected it to charge over night forgetting to change the USB setup to MSC. In the morning I found that the battery is completely drained. The clip didn’t charge even though it was connected to the USB port and showed on the clip screen that it was connected.

This is a real deadlock, I was not able to change the setting of the USB to MSC since the battery was dead and I was not able to charge since I was in Auto mode.

Finally I have noticed that it does charge for a very short while and only then it stops charging. So I connected and disconnected the clip for a several times giving it enough juice to be able to switch the USB mode to MSC and then everything went fine.

I think that the clip should always charge when connected to a USB port regardless of the USB mode it is setup to, and regardless of the SW on the PC.


You can force MSC mode by turning OFF the Clip, putting the Clip in HOLD mode by sliding the power button down so orange is showing, PRESS & HOLD the center select button, plug in the Clip to your computer, KEEP PRESSING & HOLDING that center select button until your computer recognizes the Clip as an MSC device.  Let it charge a while and then it should have enough juice so that you can change the USB mode.

Hope this helps.  Let us know it works out.

Yes, the factory default USB setting is Auto.  If you don’t have MTP capability on your host PC, this can be an issue, as the device can get stuck in a loop, trying to establish a data connection, and “forgetting” to charge.

For anyone in this situation, starting with the device off, slide the power switch to the downward “LOCK” position, and hold the center button down while plugging in.  The device will be recognized as a flash drive, in MSC mode, and will charge up.

Then, you can select MSC via the settings menu.  Be sure to reset the power switch to the center position.

Bob  :smileyvery-happy:

Both you and Steve suggested the same solution which is a good one for sofisticated useres who read this forum but what about the average user who just plug in the device and expect it to charge, especially if all the “lights” turn on.

What you described “the device can get stuck in a loop, trying to establish a data connection, and “forgetting” to charge.”  is a BUG that IMHO can be easily fixed.


Power management is a second duty of the processor itself.  This is critical, as the battery is a lithium polymer cell.

It would be nice, if the code could halt the connection process after a set interval, and default to charging only.

If the device is plugged in to a standard USB charger, this issue is avoided, but I see your point.

Bob  :wink:

I tried this trick on two different computers and it didn’t work on either. I put the clip in lock mode, held the center button while plugging it in to the usb port, held it until…and nothing. Except the compuer I tried it on that won’t recognize the sansa as anything but an MTP device kept doing the same thing, saying “found new MTP devise” “There is a problem with the installation of your hardware”

My problem is that I plugged the clip into my laptop and expected it to charge when it seemed to go fully dead. Nothing happens. I plug it into an a/c outlet and it works, and seems to show a full battery. Not sure what to do at this point. I tried resetting it, my computers are all updated, and meet the standards.