8GB SDHC card not readable by this Win 7 PC

I have just been afflicted by a problem I would not expect to see with supposedly a top brand SDHC card.  The symptoms are as follows:

1.  Yesterday, my card worked absolutely fine when plugged into my Win 7 x64 laptop - as it has done for well over a year.

2.  Today I plug it in, and I get the following error message: “You need to format the disk in drive E: before you can use it”.   Its full of photos which were readable yesterday, and are still viewable on the camera (a Panasonic).

3.   Naturally I haven’t tried formatting the disk since I don’t want to lose the photos.  However those helpful people at Microsoft apparently know all about this problem (see knowledgebase article here).  They say the format wil start, and then fail with an “unable to complete format” error message.   When the format is cancelled, the next popup tells me the card contains an “unrecognised file system”.

4.  Reading the same MS KB article further, they say the cause is: “This problem occurs when you use certain SD cards that do not behave according to the SD card specification.” 

5   And the resolution?   “This behavior is by design” - according to MS.

Elsewhere on various forums the comment is that cheap and nasty cards fall foul of this problem, but those from “recognised manufacturers” should be fine.  

So SanDisk is selling cheap and nasty cards?


I had this problem years ago with a smart media card. This was caused by  corrupt files on the card. Since the camera can still read the card, go through all the images on the card using the camera, and if any don’t display properly then delete those. That let me save the other photos. Hopefully the problem won’t recur. As for why some images may be corrupted, it might be a problem with the camera, or perhaps just some dirt on the contacts in the camera or on the card. Is this an old card?