Can not format/use SDHC 2GB card


I have a 2GB SD card and used it in my Nikon D40 for years. It worked very well.

Yesterday, when I turn on the camera, the camera said the card was bad to use and must be changed.

I took it out from the camera and set it into my laptop PC (Windows 7),  mp PC said the card was not formatted. I followed the messages from the Windows system to try to format it, but at the end there came a message as “Windows was unable to complete the format”.   

I tried to use the Windows disk management to format it, but the Windows said “The format did not complete successfully”.

I tried to use some 3rd party formatter programs, such as SD Formatter v4.0, but  they colud not format it and said that the card was write-protected, even the hardware write-protect switch on the card was at the lock-off possition. 

I checked the properties of the card, the Windows said that the capacity of the card was 0 byte.

My question:

Is it really damaged and can not be fixed?

Thanks in advance. 


in that case the card seems to be defective and you can contact the sandisk support to request a warranty replacement.

i hope its still in warranty so you can replace it with a brand new one.

Thanks deponia.

You are very welcome im glad i could help you with your issue.