8gb clip doesnt turn off: blue ring light stays on, no display and not recognized by pc anymore

Sansa Clip 8gb clip freezes and doesnt turn off: blue ring light stays on, no display and not recognized by pc anymore

This 8gb player had been working fine, and suddendly froze in the middle of a Podcast.

  • the blue ring light is on and it doest turn off

  • the display is blank, there’s no light nor information

  • it doesnt play anything anymore

  • none of the buttons do anything

  • it’s not being recognized by any PC when connected with the USB cable. The only thing that happens when connected to the PC, is that the display shows the name of the last song that was being played. The light is however very weak, as if it was dimmed.

This has been tried and does not work:

  • hold the power button for 30 secs. Nothing happens

  • hold the power button and the middle for 30 secs. Nothing happens

  • hold the power button and the middle for 30 secs while connecting to the PC with the USB cable. Nothing happens .

Additionaly:

  • the player was in MSC mode; it was working fine and was being recognize both in Windows and Linux

  • all the Podcasts are good mp3 files and had been working fine in the last weeks

  • the player is 8 weeks old and it has the latest firmware. It was bought in November 2008.

@pfict wrote:

Sansa Clip 8gb clip freezes and doesnt turn off: blue ring light stays on, no display and not recognized by pc anymore

 

 

This has been tried and does not work:

 

  • hold the power button for 30 secs. Nothing happens
  • hold the power button and the middle for 30 secs. Nothing happens
  • hold the power button and the middle for 30 secs while connecting to the PC with the USB cable. Nothing happens .

 

Out of curiousity did you hold it in the far up position (not the middle), for 15 seconds, it should turn off,  then release the on switch and try turning it on normal

>>>> did you hold it in the far up position (not the middle), for 15 seconds,

 of course !

>>>> it should turn off,  then release the on switch and try turning it on normal

no it doesnt turn off; as I said before I tried and it doesnt turn to normal

Call Tech support, sounds like a defective player to me. If Tech support cant help then you probably need to return it, or get an RMA. But the tech support guys know tons of tricks.

Thanks for your advice !

>>> or get an RMA.

what’s an RMA ?

Its something Sansa Gives you for when the place you want it wont take it back. And IS A LAST RESORT!

…listens to Queen’s “Another one bites the dust.”.

@echto wrote:
…listens to Queen’s “Another one bites the dust.”.

Actually and Litterally “All Dead, All Dead” Off of Queen’s News of the World Album

I bought it online at Amazon Germany.

Is there any special procedure to do ? Who should i contact first ?

Check Amazons Site, they have a policy. If they cant do a return, Call Sandisk and ask them about an RMA

I had the same problem with my 8GB Sansa Clip that I bought refurbished through BestBuy.

My Clip would play music files but nothing else.  My screen was dark but the blue ring would light up.

I managed to fix my Sansa Clip and took pictures and posted instructions online. 

Try it yourself by following these instructions:

http://www.bitofexperience.com/home/miscellaneous/repairs/repair-sansa-clip