4Gig Clip install problems

I bought this last December and it has never functioned.  Sandisk agree to RMA it, but changed their minds in mid-stream, told me to format the player instead.  I did that (and a million other things…) and the player is still a paperweight.  I laid it aside for a while, but want to try to get this RIGHT now, either an RMA of a successful “fix.”

XPSP3; WMP 10.

Here’s the description of the problem: the player turns on, says it’s connected, but does not show up in the “my computer” tree.  In device manager, there are 5 USB mass storage devices, and only 4 in the tree (suggesting that one is this player).  No “!” or “?” on any of them.  I was sent to “safely remove hardware” to see about drivers, same thing, 5 devices but no way to tell them apart.  In Rhapsody, similar problem: Rhapsody finds and identifies the player, but runs me in circles looking for updates (that do not exist) when I try to “install” inside Rhapsody.  I’ve reinstalled now Rhapsody several times, downloaded a suggested security update (from MS), and a bunch of other things…

Put short, the problem is that Windows is not finding the device, at least not in the functional sense.  I’ve done all obvious things, and some not so obvious (formatted, re-set, etc.)  Been through installation FAQs… nearing burnout.

Thanks for any and all help.

OK, now I have a whole other problem.  Read another thread here and tried to load using MTP.  Got sent to MS and downloaded that.  Now I have a “found new hardware”  baloon on task bar that will not go away, and Control Panel won’t let me try to install myself until the MTP install is done… it’s been running for half an hour now, and counting.  “3 finger salute” does not show anything I can stop…  I am going to try re-booting, but this is now a general computer problem beyond the Sansa player!  Urruuggghhh…!

At first, after install MTP download and reboot, the player was not plugged into the USB cord, and the status of this automatic hardware-install did not change (HUNG) when I did plug it in, nor when I unplugged it… on it goes, with no way to stop it (but maybe safe-mode).

Forget problem two.  Now I have two disfunctional “portable devices” in “device manager.”  But I still have the same original problem – no Sansa in “my computer”, no firmware update possible.

I’d like to solve it, but I am leaning toward RMA.

OK, can you connect in MSC mode?  Under the Clip’s settings, set USB to MSC; or if you don’t have that option (or otherwise), turn the Clip off and push the left-side “on” switch down into the locked position, and then press the Clip’s center button down as you connect the USB cable between the Clip and your computer.  And then I would try upgrading the firmware, if you don’t have the most recent, to see if that assists (see the firmware upgrade sticky thread at the top of the forum).

MSC mode can allow a connection where matters aren’t working out otherwise, although it can’t be used for DRM’ed files (inlcuding use with Rhapsody).

No.  Nothing I have done gets the player recognized in windows, and I have tried all modes, including the maneuver below.  The player says “connected” and Rhapsody’s system finds and identifies it, but it will not install at all in Rhapsody or in windoze.  (And now the battery is getting low, even though I have turned it off between tries).  I can’t upgrade the firmware if I can’t find the Clip on my PC.  This has always been the issue, not seeing the player on the explorer tree or anywhere else.

This is in effect a brand new device.  I bought it as a Xmas gift (…), but it didn’t work even after a few exchanges with Sansa tech. I laid it aside and have not had use of it, but thought I’d try again to get it working.  This has been a huge hassle, and still counting…


I have no idea if this will help, but in the “it can’t hurt” department, can you upgrade to WMP 11 and then try connecting up?  (At the very least, you’ll have the more recent WMP …)

Thanks MM, but in fact my initial info was wrong, I do have v11 (forgot I upgraded) and that works fine with Rhapsody and all my other media.  The Sansa player is not available in WMP 11, either.  I do very much appreciate the attempt!

I may be at the point of RMA with this and need help working my way through that system.  My earlier discussion on this w Sandisk tech has a link in it that no longer works.  The device is past its 90-day Costco warrantee but within the one year manufacturer’s coverage.

OK, bear with me, since it’s been awhile that I’ve had this problem, but sometimes Windows assigns an external device the same drive letter as already being used (heaven knows why–seems like a simple thing to me, to check if a drive is in use yet …), making the new device unusable.  The trick is to reassign the new device to a new, unused drive letter.  On Vista, you want to get to System and Maintenance, Administrative Tools, Computer Management, Storage, Disk Management, and then you can right-click a device and change the drive letter.  On XP, it’s likewise under Disk Management (or something similar–you should be able to find it).  This seems to be a random and nearly invisible issue. 

durnnit… no, the player isn’t showing up there either.  Again, thanx.