32gb cruzer blade cant format to ntfs...help please

I have a sandisk cruzer blade 32GB pendrive . I have used it once . But now the pendrive s nt working . When ever i tried to open it . Its shows ’ driver need to be formatted ’ . But as a also tried to format it its nt working . It says -’ windows has failed to format ’ . Pls help me … Hw do i get my old files back and to get my pendrive working again… Help!

Try running CHKDSK for it.  Try a different pc.  If those don’t work and your files are important you may need to find a professional recovery service.

There is a guaranteed fix to the problem of formatting in NTFS on the Sandisk Cruzer Blade 32GB USB Flash Drive…  Simply download this small HP app, and it will allow you to do it.


hmmmm Thanks mallac but this part bothers me.

OS: Windows 2K/XP File Size: 1.98 MB MD5: 0efdd4f7c091583fe5a0b4bcb7aaf76e Date Added: 2/7/2007

What about Windows 7, Windows 8/8.1 and Windows 10?

sorry if this seems a bit too basic but wouldn’t going properties>hardware>sandisk cruzer blade>policies>optimise for performance solve this problem ? it opens up the NTFS option in the format menu ( running winxp sp3). if it’s optimised for quick removal, it only shows fat32 and exfat as options. ( thanks to peter22, he wrote about this in message 20 of this thread).