32gb cruzer blade cant format to ntfs...help please

i need to put files onto the blade bigger than 4gb, exfat isnt recognized by my media player so i need this blade to be ntfs, ive tried doing it through command prompt and several programs  but no luck whatsoever, ive clicked optimize performance, in my settings the last attemp through command prompt was convert f: /fs:ntfs which seemed to work until at the end came back with “unable to notify other components that it has changed”  and when i check my usb cruzer its ALWAYS changed to raw format.

i can reformat back to fat32 and exfat and the usb works fine and accepts files perfectly but this has me stumped.

hope someone can help before i lose my last few remaining marbles ???

Try booting to safe mode then try converting it.  Or backup all the files/folders to the hdd and try a standard format command.

tried doing it in safe mode, same result, "Unable to notify other components that this volume has changed”

tried again (without re-formatting it first) command prompt now says the drive is already ntfs , however in properties the usb cruzer is showing in a state of raw .

also in command prompt tried format f: /fs:ntfs  which attempted to format the drive but came back with “the second ntfs boot sector is unwriteable”

“format failed”

Can you run CHKDSK on the drive?

yes when its formatted in fat32 mode

no when its in a state of raw after the convert to ntfs failiure

1 Like

4gb cruzer blade cant format to ntfs…help please

@anshumans006 wrote:
4gb cruzer blade cant format to ntfs…help please

Why would you want to?

1 Like

becuase there is a 4gb per file  limit on fat32

Well, if the drive is only 4GB, you won’t be able to put a 4GB file on it anyway. A 4GB drive is only about 3.7 something GB of available space.

lol, didnt notice he had put 4gb, my bad lol

well ive tried formatting this usb on several xp’s, a vista and a windows 7 and no luck whatsoever, luckily a bloke at work has a mac and i did it in 5 mins, if anyone else is having trouble and ripping their hair out seriously just use a mac for it, ive tried for almost a week now formatting, deleting partitions etc etc etc etc and it simply wasnt worth it.

note to sandisk must do better , MUCH better

well ive tried formatting this usb on several xp’s, a vista and a windows 7 and no luck whatsoever,

note to sandisk must do better , MUCH better

Sounds more like a Microsoft problem than a SanDisk problem.  Of course the other common element, you. :smileyvery-happy:

BTW I suspect a Live Linux CD would have worked also.

i would have suspected the same myself, however ive tried 2 usb flash drives (cheap ebay no name usb’s) and ALL of them formatted perfectly to NTFS on the same pc’s/laptops and while ive been looking on the web ive come across a fair few people who have had the same problem, so its got to be a sandisk thing, got to admit but the cheap ebay flash drives have been a joy to use compared to this nightmare usb.

hmmmmm  When you tried to format it were there files & folders still on it?

nope non at all, thought it might have been u3 but nope not hidden folders or anything

hmmmm I know under Win 7 a drive can be flagged as Read Only if part of a HomeGroup so I can understand Win 7 preventing you from formating the drive if that has happened.  But I don’t see how that would carry over to Win XP.

There are various solution senarios described on Google.  From registry hacks to Safely Removing the drive, reinserting it and Safely removing it a second time.

Someplace, somehow, Windows is setting a bit or byte which is making the drive read only and various versions of Windows are supporting that bit/byte.  The MAC’s OS obviously isn’t.  And the problem isn’t limited to SanDisk drives from what I saw on Google.

Definitely a mystery.

yeah i think the other one having issues was a kingston flash drive. there is a bug somewhere between windows and sandisk/kingston.

just for anyone else, the pc’s i used where xp (sp3) xp (sp2) vista and 7, which all formatted the cheap ebay ones to ntfs and back to fat32 with no issues , the sandisk wouldnt format on any, i cant say for the kingston obviously as i dont have one.

There has to have been an error in the drive’s FAT.  And the usual reason for errors in them is removal without using Windows’ Safe Removal option.

Since you seem to be a tech, the next time you encounter the problem;

Use a utility to dump/save the drive’s first sector.  Utilities such as TinyHexer, or FSutil and DSFOK’s DSfi.

Then zero out the first sector.  The previous utilities should do that.

See if you can then format the drive.

Let us know what happens.  :wink:

I certainly will do, just to get other people out of this annoyance hopefully


I bumped into the same problem, but managed to solve it within WindowsXP.

First it failed:

C:\>format /FS:NTFS e:
Insert new disk for drive E:
and press ENTER when ready…
NTFS file system is not supported on this device optimized for removal.
To change the way this device is optimized, select the Policies tab in
the device’s property sheet.

So I changed device policy from “Optimize from quick removal” to “Optimize for performance”.

Next time it went better:

C:\>format /FS:NTFS e:
Insert new disk for drive E:
and press ENTER when ready…
The type of the file system is FAT32.
The new file system is NTFS.
Verifying 30532M

Format cannot run because the volume is in use by another
process.  Format may run if this volume is dismounted first.
Would you like to force a dismount on this volume? (Y/N) y
Volume dismounted.  All opened handles to this volume are now invalid.
Volume label (ENTER for none)? Stick1
Creating file system structures.
Format complete.
  31265292 KB total disk space.
  31198592 KB are available.

Perhaps this can help others experiencing same problem.

Best regards, Peter