2GB microSD not responding

I figured that was the case.  Was it a large warning?  I only ask because I can’t see it anymore.  I got the same FW.

On a side note:  The user interface runs nice and smooth when I remove the micro SD card…

Sad note it seems to lag some of my computers to have the Express connected with the SD card installed :frowning:

The SD card is fine.  I can use it in other devices and use it’s adaptor to modify it’s contents.

Yes, I am pretty sure that I have the same firmware as the person who has a 128 MB card. It is the higher capacity cards that have problems. I have a 64 MB card that works most of the time with the Sandisk (sometimes it has been flaky since the upgrade). Every day, I’m checking the open support case that I have and so far, no answer since 8/12. Has anyone else heard what the expectation is for when we will get new firmware?

Just realized I have a 2 year Best Buy Product Replacement plan…  Time to cash in…  Sad really.  But I really want my Micro SD slot back without having to buy other cards.

Same story.  I bought a Sansa Express and a Kingston 2GB microSD.  They worked fine till I upgraded the firmware.  It took me hours of work to get it back responding without the microSD.  Seems to be a firmware problem

Happened to me last night! THIS IS A DISASTER. I really like this
player, I can operate it with one hand, and it even gets looks. Great
for traveling.

I get it Monday, take it on a trip, go from WM9 to WM11  Wed night which causes
the updater to fire up for the first time, and I had been on this forum!
I knew! (I guess the end result will be to RMA the player back to tiger
direct and let them sort it out, and buy a new one.)

Upgraded with the 2G card in the player. I think this might be the mistake.

I have tried updating with the asia/pac and Japan firmware versions. No joy.
I think the only difference is the language support (though if the update did
touch the microSD card, then maybe a real format might do the trick.)

Formatted the 2G Kingston card in my camera. Camera can use the microSD,
but the Express still complains by not mounting it and running in super slow mode
with the microSD card in place.

Format in the Express does nothing. Though the Camera clearly is not really
formatting the card, it goes way to fast. My other camera sort of works at the
formatting (uses other types of cards.)

Tried MTP/USB Mass Storage mode. No joy. Thought in USB mode I might
be able to format the microSD card with Windows.

What is interesting is that while the player does not show the card is mounted,
it must be trying to mount it, that explains the fact the player goes into super slow
mode. Maybe the formatting is slightly off and that is the problem.

I also noticed a long of songs did not transfer correctly, the song is in the database
but the song is not present. Another issue with the new and improved firmware.

Sandisk support did respond quickly, they suggest formatting with an external card reader
FAT32. Guess I will buy an external card reader. Sandisk response does not really
fully express understanding of the issue (and why does the internal Format mode of
the Express not work? Or is that just really “delete all”?) There is a hint of it has to
be a SanDisk card in the email as the email refers to “formatting the Sandisk card”.

Off to the computer store tomorrow for an external usb card reader.

Here is the support email:


Thank you for contacting SanDisk Technical Support. It is our goal to make sure you have all the resources you need to get the most from your product through your recent inquiry into our product line.

For verification, does your computer have Windows Vista or Windows XP as operating system? Is it a desktop or a laptop? May we ask for the make and model of your computer (please specify if it is custom built)?

We may have to format your microSD card using a card reader if your Sansa Express cannot provide another icon to show the microSD when it is plugged to the player and the player plugged to the computer.

What we strongly suggest for cases like this is to perform a Full Format using FAT as your default file system using your reader connected directly at the back USB port of your desktop computer or a self powered USB Hub.

Caution: Formatting will erase all information on the drive. Please be sure to back up all information before proceeding to format the drive.

To format the SanDisk card on your PC, go to “My Computer” on Windows XP and lower versions or “Computer” on Windows Vista, single right click on the Removable Disk ( “”) : associated with your SanDisk card, and select “Format”. On Windows 98SE or Windows ME, we will simply single left click “Start" to begin format. On Windows 2000 and Windows XP, let us please make sure that, under “File System”, we change FAT to FAT32, and then single left click “Start". This will erase all data off the SanDisk card and correct errors on it, which should make the SanDisk card usable again.

We also recommend formatting the SanDisk card another way. Please be advised that formatting will erase all data.

If you have Windows Vista/XP/2000:

Please right click on “My Computer” on Windows XP and Windows 2000 or “Computer” on Windows Vista and select “Manage”. When “Computer Management” comes up, please click on “Disk Management” on the left hand side. After clicking on “Disk Management” you should now have a list of drives in the right side panel. On the right, look for the SanDisk card, it may show up as Disk 1, 2, 3… Removable Disk. Right click on the larger “Volume” rectangular icon to the right of the Removable disk and select “Format” choosing FAT32. If you do not have the format option, please select “New Partition” and just keep clicking next through the Wizard that appears.

After you have formatted the SanDisk card, please test it.

Please try the procedures on another computer if it fails in your computer.

For registry and warranty purposes, please provide information on the following: a viable telephone number, the original Date of Purchase, the original Place of Purchase, the product part number, color of the player, the model number (should start with SD) and the physical address. No P.O. Boxes, please.

Should you have any further assistance, inquiries or concerns, please do not hesitate to reply to this e-mail.

Best regards,
Vykmon G.
SanDisk Technical Support_


My mail to them:

_This week purchased a Sansa Express 2Gbyte.

Extremely satisfied until I updated the firmware.

Now the 2GB MicroSD card is no longer recognized and
the player does not operate correctly with it installed.

I had to learn that removing the 2GB MicroSD card would
restore function from the Sandisk User Forum.

The player will not format it, and in USB mode, no
external card is detected.

The update was performed with the microSD card installed.
I assume this is the fault, and the microSD must be
formatted externally again before use. According to
an external forum.

I am badly disappointed that this problem is clearly and widely
known to both the Sandisk supported user Forums and
on other Forums, yet no steps have been taken to avoid
this problem for additional new owners by at least stopping
distributing this update.

There is a report that updating the player to the asis/pacific rim
firmware will fix the problem. It does not. Nor does
installing the Japanese firmware version. They seem to
differ in the language and default language.

Normally someone writes something like “I will never
buy another Sandisk Product ever again” at this point
… well … now maybe if sometime tomorrow this is 
all resolved. A great experience turned into a frustrating

No joy. Bought a external card reader, formatted FAT 32. No change
in behavior. What a crock. No wonder people buy Ipods. My old
Rio Riot was better (also had lots of little fussy issues.)

I don’t think I am game to buy a Sandisk 2g microSD card to prove
it is Sandisk limitinng Sandisk players to only Sandisk memory cards.

Do not upgrade your player to a new firmware unless broken.


Once I get my SE back from RMA, I’m gonna test to see if only Sandisk cards work on this thing.

On the another note,
is the c series having the same MSD problem?

I talked to Sandisk support on the phone today. Very professional,
they offered to RMA the player which I will eventually do (I bought
the mp3 player now because I needed one for travel.).

I tried to discover if Sandisk was actually aware of this issue
as a known bug, and that was not very clear in the end. A lot
of “I am just the phone tech guy what can I do but RMA it?”

The phone tech did say there would be a new update in a month
and that I should not update the new player. But the suggestion of
a update in a month could be just so much pleasant talk.

Clearly a problem with a large non-integrated manufacturer.
There are probably at least 4 entities involved, hardware design,
software design and they might or might not even work for Sandisk
(could be contract.) The Sandisk corporate, and of course sales and
marketing, and then the user support. And it is not like the tech on
phone can call down to the code developers and say “what’s up”.

And if it is in fact something about DRM, that if I have a subscription
service, and if it stored music on the microSD, I can remove the card
and then by hook or by crook get the music off the player and
remove the DRM protections. I would be curious if the player’s behavior
changed wrt to subscription services after the upgrade.


Exchanged it at Best Buy.  Works just fine now.  But it does seem like a more recent Firmware Version… V1.00.15A2

I won’t update until Sandisk addresses this bug specifically.  This is very poor for a business to say “Upps Just RMA it”


As a software developer for both embedded products and PC products I can say this just makes my stomach turn everytime I think about it so I am going to save myself the stress and never return to this Forum or Sandisk’s site.  Good luck to everyone still up the creek!

I am noticing additional problems with 01.01.01A (might have been in 01.01.01 too.)

While copying songs in USB MSC mode today, a bunch of songs are Unknown Artist, Unknown
Album and song title is 01-Tea~1.mp3. Explain that. Earlier transfers are
fine. Either the filename or if the tags are too long or contain special character …
Rio Riot works with these files … Windows Media shows the right information … everything
but the Sandisk Express … if I mess with the MP3 is eventually fixes itself … I saw a
“no song” that fixed itself.

Eventually everyone ends up with an Ipod :frowning:

Interesting in Window Media 9 it was easy to edit the tags and get album information
on a song while it was playing, just right click, not in WM 11, have to be in library mode …
that is an improvement :wink:

V1.00.15A2, I think that is even a older version 01.01.01.


I have the same problem. I bought 2GB microSD card. It worked fine for while until the battery of the player was completly drained. Since then the player cannot recognize the memory card.

Just bought my 1G Sensa Express from Singapore. They have thrown in a free 1G Sandisk MicroSD. So far it is working fine. After reading this forum, have decided not to install the firmware update. :)

broken_already wrote :-

>"While copying songs in USB MSC mode today, a bunch of songs are Unknown Artist, Unknown
>Album and song title is 01-Tea~1.mp3. Explain that. Earlier transfers are
>fine. Either the filename or if the tags are too long or contain special character …
>Rio Riot works with these files … Windows Media shows the right information … everything
>but the Sandisk Express … if I mess with the MP3 is eventually fixes itself … I saw a
>“no song” that fixed itself. "

Btw, what is USB MSC mode? So far I have use my Windows Explorer to directly write MP3 files into both the 1G internal and 1G external. Initially I also experiece the problems that you have mentioned below. What I did was to delete those files from Sensa Express. Pull it out and let it “rebuild the database”. Simultaneously, I use Windows Explorer to create the album title and title for my various files. Then I plug it back to my USB, copied the files back, and unplug it again to allow it to “rebuild the database”. Now it can show the songs by Album correctly.

Message Edited by ngcw on 09-02-2007 07:46 AM

Hmmm, I’ve got a 1GB SanDisk microSD from Best Buy and updated my Express.  Everything still works fine…  So far…  :slight_smile:

I just learned this the hard way.  Same story.  Kingston MicroSD.  Updated firmware.  Doesn’t work anymore.  Found this thread and it’s at least a month old.  Why is this firmware still available?!!  I am furious!  I bought this player for this very feature and after less than a week it doesn’t work and it was nothing I did but the manufacturer itself! 

This was on sale this week, so of course when I went to exchange it, they are all out of them.

Sandisk has made another unhappy customer.  Either fix the issue or allow us to regress it back to the old firmware.

Same boat as all the rest of you, bought a 2GB kingston … almost bought the sandisk 2GB but the kingston had free shipping ($1-2 cheaper) and I thought was a better brand.  Well I am going to mess around with it more to see if I can get lucky (maybe reformat a few time and hope the problem disappears).

>Btw, what is USB MSC mode?

USB can have different OS drivers. MTP which is a portable player specific driver that microsoft supplies
with Window Media Player 10 and 11, and “native” on Vista.

USB MSC is the standard USB mass storage driver (same that works with various thumb drives
and USB external drives.)

The Express will default to USB MSC when MTP is not available (or better put Windows will install
the MTP driver and it wins when the Express is installed unless you change the driver in
the windows hardware manager.

Wikipedia has some good introductions. Before MTP each portable device had its own driver.
Apple and Ipods use “Isync” over USB for example.

I was thinking back a few decades, about the rumor Sun Microsystems did not burn in test
their computers. Instead they let them fail in the field, and just ship new parts. I assume MP3
players don’t get a week of operation at elevated temperatures before final acceptance testing either :wink:


I have finally found a solution to the problem described in my previous post. The trick is to change Express’ mode to MSC. Once the mode is changed to MSC windows will recognize SD memory card as an external drive. You will need to format it. After the format is finished, Express will recognize the card and you will be back in the game.
In order to change the mode to MSC follow the instructions below:

  • Click on the Start button and Select Settings. Then click on Control Panel. 
  • Double click System, and then select the Hardware tab. 
  • Click on Device manager. 
  • Click on the ‘+’ for Portable device and you will see “Insignia Video Player”. 
  • Right click and select “Update driver”.
  • A Hardware Update Window will open, Select “No, not this time” when windows asks to search for software.  Click next.  Check the “Install from a list or specific location” checkbox and then click next.
  • On the next screen select “Don’t Search. I will choose the driver to install”. 
  • Click next and then you will see a window showing two drivers that are compatible with your player.
  • To put the device into MSC mode select “USB Mass Storage Device” and click next. 
  • A finish installing driver will appear and your device will now appear as a hard drive on your system.

Hi James,

I have a Lexar 2GB. My mp3 player was working fine yesterday, all of my 300 songs were showing up on the screen. Came home to recharge and add some new songs, the expansion card icon would not show on my computer. Took a look at the mp3 player, the number of songs went down to 200. My son searched, formatted, etc. This morning I only had 200 songs. Came home to recharge plugged in the mp3 and still no expansion card icon showing. How do I get my card to show again???

I recently purchased a Sansa Express. I bought a pq1 microSD card to use in it. They play wouldn’t recognize it and I contacted SanDisk support. They said the MP3 player only supports SanDisk microSD cards right now. I can not believe that when using an industry standard such as microSD that they would do this!

I would have to pay 55 bucks or more for a SanDisk 2GB microSD when I bought another brand for $24.

This is part of the response I got back from SanDisk:
Please be informed that as of this moment that the player can only recognized SanDisk MicroSD cards. However, we are now making an update for the player in order for it to recognized other MicroSD cards.

I plan to return mine for a refund as this is unacceptable to me as a consumer. I would recommend that to anyone else that still has the chance.

Message Edited by thompsonmkt on 09-28-2007 10:44 AM

So I guess the answer is they don’t care, they are not going to tell you before you buy it about this problem, and they’ll fix it when they’re good and ready.