2GB microSD not responding


I bought a 2GB microSD and it seems that the Express does not recognize it at all. I see it with a card reader, but once back in the express, nothing is seen. What’s more, when the card is in, the express is extremely sluggish, becomes unstable and eventually unresponsive.

I thought the 2GB was the currently supported limit (with the hope of firmware updates to support bigger minis later).

I’ve formated the external disk twice with no change.

Please advise.


I’m experiencing this also.  What brand of memory card?  Mine is a Kingston.  I’m running firmware 01.01.01A.  There have been reports elsewhere that earlier firmware versions do not have this problem (see link), but there doesn’t seem to be a supported way to revert to an earlier version (come on, Sansa, that should be easy…)


You hit it right on the head.

Mine also is Kingston. And I also am running the same firmware version (also most current).

I like this player quite a bit, but one main reason for buying was the microSD expansion capabilities. SanDisk can you address this in your next firmware update or provide access to earlier versions?



Can you post the card code that is printed on the Kingstons?  I have 3 Kingstond MicroSD cards myself that seem to work with no issue but I do not have a 2GB version which may be the problem.

I, too, had a Kingston 2GB micro-SD card and I couldn’t even get a card reader to recognize it, so I bought a SanDisk 2GB micro-SD card.  It worked for a while but eventually, the Express wouldn’t recognize it.  I have reformatted it but I just can’t get the Express to recognize it.  My card reader does recognize the SanDisk card.

It appears the item number is SD-C02G and the other number on it is 0722Y68943V. Again, it works fine in a card reader, but not in the SE. The card is new and purchased for this device.

I too am having the same problem with the Kingston card, but on mine it did work OK until I updated the firmware yesterday, so I have to assume it is a firmware problem and not a problem with the Kingston card and with SanDisk’s upgrade program, it looks for what’s installed and auto upgrades from there. I haven’t found anyplace on their website to roll back any firmware. The version I update to last night is 01.01.01, and I don’t know what I had before, but before it worked and now it doesn’t.

As a follow up, I had a Sandisk 128MB card I inserted. In Windows MediaPlayer, it let me sync a playlist and looked like everything was fine. I removed the player, restarted it and although there was no lag, it couldn’t see any playlist or music at all on either the internal memory or the 128MB SanDisk card. I removed the card and mysteriously all the internal music now shows up and plays. The playlist and songs copied to the 128MB card play and work fine, just not in the Express player. So I now doubt it has anything to do with the Kinsgton 2GB card since I’m getting, not the same, but a similar problem with SanDisk’s 128MB card. I say not the same because I can’t even sync the Kingston card while it’s in the player. The Sandisk card will sync while in the player, but it’s useless since with it installed the player can’t see any of the music on it or in the internal mememory. 

Same problem here, with something of a workaround (but one I consider unacceptable). I wonder if this has to do with low power conditions?

Bought a Sansa Express 1 MB, and a Lexar 2GB microSD with it. Hooked it up to XP and installed 01.01.01A firmware, then copied files to both chips (internal and the Lexar card). Listened for a while, then connected to my laptop to charge overnight. Next morning, dead Express. I learned that laptops might not put out enough jiuce on the USB port, so I bought a separate AC/USB charger and charged overnight again. Next day, no songs showed up from the microSD card. Upon further investigation, the card itself was not acknowledged by the player. As if it wasn’t even present! For a while, I thought maybe the slot had gone bad.

I tried formatting and reformatting from the player software, with no luck.

Finally, I inserted the microSD into its full size SD adapter and then into a separate USB 8-in-1 card reader. Used Windows XP to reformat as FAT16 again.

When I returned the card to the Express, it was recognized and worked as before, with no problems. If a standalone card reader and computer are *required* to fix this bug, this is unacceptable. When I’m on the road, I don’t have these things handy.

Whether this is a firmware bug or a power loss problem - it’s a mistake and it should be fixed. It’s a convenient and cool little player, but I did not buy it so that I could work out solutions to problems that it should not have in the first place. I refuse to beta test a problem this rudimentary. There’s no way I can prevent it from running down power to some “mystery point” where it corrupts the microSD chip… I’ll try to reproduce this, and if I can, it’s going back.


Message Edited by jamesmhebert on 08-01-2007 09:56 PM

This is definitely related to the firmware upgrade…mine had been working beautifully up to that point. Don’t have a card reader, but have tried re-formatting the card in my Canon Ixus and PS3 to no avail and yes the card is a Kinston 2gb.

Sandisk… anyway to regress to the previous firmware version?

I haven’t had this problem, but I don’t have a Kingston card, so that doesn’t count.  I’m curious, though.  What if you use the Sansa Firmware Updater to change the region and load the PacRim/Asia firmware?  You get the region drop-down if you click on the updater icon and select “Check for Updates Now”.  There may be no way to roll back, but you can try overwriting regions and see if that works for now.  Maybe the American firmware just didn’t load right…

Same problem here. No response from sandisk

Same here, I’m from Brazil, and my friend gave to me a sansa express 2 months ago. Now the computer says it’s in mtp mode, and don’t turn on.

I think it’s hard to belive that sandisk replace my sansaexpress

As I stated in a previous post, I have both a Kingston card and a 128mb SanDisk card, and I’m getting the same error on both. You suggested trying the PacRim/Asia update which is what SanDisk also suggested, however, I have downloaded, installed, uninstalled,reinstalled 3 times and clicking update now doesn’t give me any options to change the region. After clicking update now, it gives a dialogue box stating the firmware it’s detected and an option to cancel or continue. Selecting continue just says that my firmware is up to date which is 1.01.01.

I received a reply from SanDisk. they were originally going to email me the older version of firmware, but later responded back that it was for internal use only and they weren’t allowed to send it out. The good news (maybe?) is that they are having problems with Kingston and PNY cards as well as some SanDisk so thier firmware coders are working to resolve this in the next update…whenever that may be. At least it’s acknowledged and someone is supposedly doing something.  

Is there any further word on getting the firmware corrected? Stupid me updated on Tuesday without reading the forums and now my 2 GB Kingston microSD doesn’t work, either. I tried the trick of formatting as FAT16, but it still doesn’t work.

I also have a 2GB memory card that is no longer recognized after upgrading to the latest firmware.  Its very strange, when I insert the card not only is it not recognized as memory but the whole user interface is very slow and buggy while the card is in the player.  I spoke to sandisk technical support today and they told me to send it back to the seller for an exchange.  I’m trying to reformat the memory card to see if that makes it work, but I’m having no luck.

How are we supposed to return when I’m way past 14, 30 or even 60 days from when I bought it. That is unacceptable. Sandisk’s firmware broke it; I expect them to fix it. I work as a software architect in the software business, and I would be “strongly” told to fix it or get out of the way so someone can fix it. I expect nothing less from Sandisk.

Same here…  Kingston CD-C02G 2GM Micro SD card no longer visible under Windows XP Pro.

Although it does run through the Building Database progress bar for a period of time then it continues to function.

System Info does not show any information regarding the SD card,  and my UI is slower than I can manage to look at!

Anyone see a warning stating that your internal flash would be erased as a result of the Firmware update?  I saw NO LARGE warning telling me to back up my data before upgrading the Firmware…

That was very poor SanDisk… Wow…  I really liked my Sansa Express…  But over this deal…  You have forever lost one customer.  Why waste my money on a company that willingly does this to their customers?  Almost makes me sick thinking about it…


It does warn you.  I canceled the FW upgrade and backed up all my music first, then I updated then copied it back. I upgraded mine last night to see what the commotion was all about.  My SanDisk 128mb MicroSD is still being recoginzed by the PC and Express.  With the card inserted, i dont seem to notice any slowdown.  Menu navigation is normal.

What is the FW you guys got?  I have 1.01.01A