2GB microSD not responding

I found this funny,
My computer, installed my SE as a MSC when I plugged it in and after 4 seconds unplugged it and then replugged it in for the first time.
To switch back to MTP I just deleted the MSC drivers related to the SE and then plugged the SE back in w/o unplugging it and replugging it in.

Haha, it’s funny. But I’m using Vista so I’m not sure if this trick works for XP or such.

I tried a suggested fix - reformat to Fat16.  Still doesn’t recognize card and it total messes up playing songs - they skip as though the device is too busy indexing the card to play the song.  This whole problem occurred when I foolishly updated my firmware from 1.00.15A2 to 1.01.01A2.

Called the tech support line - their story is that Kingston uses a different controller and won’t work with the Express.  Ordered a Sandisk card with mini and std adaptors from Amazon ($30).  We’ll see if that fixes the problem.  I suppose I should be content with the base 2gb, but the slot is too irresistable.

Message Edited by pawinterks on 10-18-2007 11:33 PM

But it did work before the firmware upgrade.

Anyway, Staples had a sale week of Columbus Day and they had Sandisk brand for the same price I paid for Kingston, so I guess I’ll just use it in my camera with the adapter.

Sandisk 2GB SDMicro arrived.  Worked fine although I had an issue with the indexing not refreshing properly - showed songs and then wouldn’t play them.  Turning off and then on finally forced a full refresh and things seem to be working OK now.  If they could just get the resume feature to work correctly without having to resort to power off to save your place.

1.01.01A2 hasn’t caused any problems for me. I’ve been loving my SE ever since Sandisk sent me my RMA.

I’m in the same boat.  2GB Kingston microSD card not working…
I’ll post a message to their tech support, lets hope something good comes out SOON.

I gave in and bought a Sandisk 2gb microSD…and it works perfectly. Will use the Kingston with my camera and an adapter :frowning:

I found one less than $20 and gave up on firmware fix…it doesn’t appear that this issue is a priority. I started this thread in JULY!!!


Bretzke, where did you find your 2GB Sandisk card for $20?  I can still send my Kingston one back, which cost $25…

I found it on Amazon from a 3rd party lister. Here is the direct link:


Came in a small padded envelope and works great!


When i put in my 2gb microSD   memory card it is saying that disk is not formatted.

What do i do?

Settings - > Format -> External -> Confirm

New version of the Updater today… but still no actual firmware version update. ugh

Sandisk just sent me the firmware rollback that made my express recognize the 2gb Kingston Micro SD cards.  Anyone still need it?

prozema wrote:

Sandisk just sent me the firmware rollback that made my express recognize the 2gb Kingston Micro SD cards.  Anyone still need it?

yes please. chilleddesi(at)yahoo(dot)com


yes please - andyandbuster(at)yahoo(dot)com.au

Did this fix the problems?  Were there any ill effects?

Thanks heaps!

No ill effects that I have noticed after rolling back the firmware.  The only change that I could see is that my micro SD card finally worked again.

Please email old firmware to:


Thanks a bunch!

WOW!  If it’s not too much trouble, I’d like a copy of the firmware at

Thanks a bunch.

Message Edited by caligula on 11-14-2007 06:58 PM

Message Edited by caligula on 11-25-2007 07:21 AM

Can you send me this Sw too (podniesma@wp.pl)