2GB Fuze No Longer Recognised (and "FAT is corrupted" etc.)

Right… Well. I recently accidentally may have mis-formatted my 2GB Fuze as FAT, rather than FAT32 (or whatever it’s meant to be).

The message on the screen (whenever I turn on the Fuze or connect it) is

“FAT is corrupted. Please connect device to PC and recover FAT.”

Thing is, I’m not sure how I’m meant to do this. It isn’t recognised by Windows (it comes up as “Unrecognised USB Device”, and won’t let me access it or format it or anything, doesn’t even get assigned a drive letter and there’s no option in Manager). In Ubunutu, it’s recognised as a mass storage device, and I can still see all the files that were on it before it stopped working, but I can’t format it or do anything with it (although I could copy off the files).

Has anybody got any ideas on how to fix this? =(

(I don’t mind losing whatever’s on there, I have it all on my HDD anyways)

Thanks <3

EDIT: Also, I was in MTP when I tried formatting first time round (before it broke), but I can’t get into the player to change to MSC because the formatting is messed and it can’t load the UI…

Message Edited by Tyrotoxism on 05-02-2009 11:56 PM

The Fuze can be manually forced to MSC mode:

Start with the device OFF.  If “frozen”, press and hold the power slider in the ON position (20 seconds) until it powers off.

Slide the switch down to the LOCK position (orange showing).

Press and hold the center button while plugging in to the USB port.

From Windows, you can format the device as a FAT32 volume, though FAT is correct for the 2GB Fuze.  In WIndows XP, you can right click on My Computer with the Fuze connected on MSC mode, select Disk MAnagement, then you will have access to the Fuze to run a disk check and format in FAT.

µsansa

Alright… That got it recognised, and I can see it as a drive now, but I still can’t format it.

Here’s a screenshot of what happens; (I’m using W7 Beta)

Screenie
Message Edited by Tyrotoxism on 05-03-2009 04:57 PM

Tell the application (right drop downs seen in the shot) size is 2GB, allocation cluster is to be 32KB, file system FAT.  I am always nervous when seeing “default”.  Well, you see the obvious results.

Let’s assume that the logical drive letter assigned is “L:”

Can you go into the MSDOS window?  Enter Format L: /FS:FAT /A:32K

Bob  :smiley:

It doesn’t let me choose a capacity, and when I choose the value (inc. 32KB) as the Allocation Unit Size, it still doesn’t work.

=X

It might be part of the “beta” issue.  Can you try another PC with an intact OS?

Bob  :stuck_out_tongue:

'kay, well.  Tried it on XP.

It just does the same thing, except that with XP, the format menu doesn’t open (I’m guessing that XP just doesn’t let you open the menu if the device can’t be formatted, rather than give you an error after trying).

*sigh*

Also… With the Command Prompt, I still get the same error as when I just typed “Format L:” as I do typing the details.

Message Edited by Tyrotoxism on 05-03-2009 06:39 PM

With the XP machine, see if you can navigate within any folders using Windows Explorer.  If not, verify that the comm session is okay using the Device Manager.

Bob  :wink:

Well… When it’s in XP, I can access the device, but it doesn’t show me anything. I didn’t try copying anything over, but I doubt it would’ve worked…

Well, I could get at the player, but it didn’t show any files/folders etc…

Right, well I used this tool to format as FAT, and I can access it now. 

Everything seems to be working fine, so I’m happy. 

Completely forgot that all built-in Windows utilities suck. :stuck_out_tongue:

I have the exact same problem, “FAT Corrupted” and I had tried so many times but I still can’t get the device to be recognized.  I use a Windows XP SP3.  Whenever I tried your ways, it always say “USB device not recognized”, “malfunctioned” 

I need additional help

One thing that you could try, is to install Sansa Updater and with some luck when you’ll connect your Fuze, it will automaticaly go in recovery mode.