2GB Clip loads some songs, not others without explanation (using MTP)

Just got a 2GB Clip today (yay, $20 sale) and I cannot get it to work.  I’m running the latest Songbird on Windows XP. First, the basics:

  • I have the latest firmware (v02.01.32A)
  • I’m using MTP exclusively (for now, because it seems neat. I’d like to use this under Linux, though, so I might switch to MSC even if I can get MTP working)
  • I have no music using DRM.

I started Songbird, plugged in my Clip, and Songbird immediately detected it properly. First I manually added songs through Songbird and then looked in the Internal Memory/Music to verify the music was there. When I disconnected and tried to play, some songs worked and others didn’t. Some were OGG, some mp3, various bitrates, some with embedded album art, some without. I deleted everything and tried again using the automatic playlist sync of Songbird. This time, the songs that wouldn’t play before won’t even copy to the device.

Oddly, exactly one song that did play before now won’t even copy.

Whether Songbird is loaded or not, I cannot copy files via Windows Explorer into the Music folder.  I get the “you do not have permission to create this item” error. This seems like a Windows permissions issue, but I don’t understand why it suddenly started happening, nor how I stop it.

  1. Can anyone suggest a way to fix this?
  2. Is it worth fixing, or is MTP not worth the headaches?
  3. Does MTP even work with Linux?