16GB Kingston microSD ain't workin' -- HELP

I have an 8GB Fuze.  Fuze has most recent firmware release.  Worked fine with 4GB card.  Got a 16GB Kingston card and it freezes during database refresh most of the time.  I have tried it with about 7GB of files on it and it won’t refresh.  I have tried it with one single file on it and it will refresh.  I am trying it as I type with 778MB of files on it and the verdict is…hmm, puked and restarted itself.  I’ve seen that before too.  It happens about every tenth try.  Right before restarting if gives some very brief message about a corrupted FAT table or something.  Too fast to read.  I have formatted this card from command line per the suggestions mentioned in this forum.  Second time around (after auto-restart) with 778MB results in a hung device during refresh.  FWIW, I am trying to load it up with ogg files.  Now I am trying it with a single album in a single folder and…that worked.  Great, I can get one album on a 16GB card.

I have no problems reading or writing to this card using either a standalone reader or the Fuze.

Pretty annoying.  I am really not interested in having to try and buy another card (obviously I would try SanDisk) and having to try and return this one or sell it on fleabay or some other further hassle. 

Sansa tech support is not responding in a timely fashion. 

Any ideas folks???

Thanks,

Michael 

Some people have reported compatibility problems wiht Sansas and Kingston brand cards, but that’s usually limited to video files.

Hanging during the database refresh is usually indicative of a corrupted file(s) or bad or foreign info in (or the wrong format of) the ID3 tag.

I’d try loading 1 album at a time until you find the problem one. Then you can examine the files in that album to determine the problem or what is different about that one that your Fuze doesn’t seem to like.

Thanks for the reply.  I am pretty sure that all of my ogg tags are good.  I will see if I can load it fill it up with FLACS or mp3s.

Ok it does seem that there are certain files it doesn’t like.  The files in question had both brackets, wickets, or other special chars in the filename and both brackets and asterix in the tag.  Again, these were ogg files…dunno if that matters.

Pain in the rear bug. 

Should be an easy fix to get that handled properly.  

Scratch that.  I made some test files to verify that special characters might be the problem.  They aren’t.  My test files had [] or # in both the tags and the filenames and the refresh went just fine.

This really sucks having to go through trial and error to see what I can and can’t put on the Fuze – with 24GB worth of files it is a REAL PAIN IN THE REAR.

I have inspected all of my tags visually with tag and rename and they all seem to be in order.  Is there some other utility that I could use that might help me ferret out problem tags (assuming that they are the source of the problem). 

MP3TAG

One thing to check is whether the problems files have the right format of ID3 tag, as well as crapola in the Comments field. This should be empty.

The best format to use is ID3v2.3 ISO-8859-1.