16GB Cruzer not showing correct amount of storage

I purchased a 16GB SansDisk Cruzer model: SDCZ60-16G

I used it to perform a system restore for my Chromebook and after the installation went through the drive will only show 1.96 of 1.96MB available. 

I have tried to format it every which way. I was wondering if anyone has experienced this issue or if there is software to factory reset it. 

Any info you have I would greatly appreciate.

How did you get the System Restore onto the flash drive?  What did you use?

When I purchased it, it worked fine, showing the correct amount of storage. But after I installed the software the flashed the chromebook it only reads the 1.96MB and saying there is nothing on the drive.

I’ve never used a Chromebook so I can’t say for sure what the problem is but it’s possible Chromebook’s recovery process now owns the flash drive and that’s all it can be used for from now on.

It’s also possible the Chrombook’s recovery app partitioned the drive and you only have access to the 1st partition at this point.

Let us know what you find out.

Alright, figured it out! 

For future reference, you need to have the chrome-os image recovery installer:

  • you run it
  • select other option
  • format media

Hope this helps some other poor sap :wink:

source: http://www.samsung.com/us/support/howtoguide/N0000442/6833/45819/N/2/M/