16GB Cruzer Contour USB drive became 2x64MB

I used a Cruzer Contour 16GB USB 2.0 drive for almost 5 years, but one day it just turned into two 64MB drives. Windows even recognize two separate devices. Tried formatting, messing with GParted in Ubuntu. I also tried to install U3 functionality, which I removed long ago, no luck. Is it possible to fix the drive?

Very strange.  If GParted doesn’t see more than the two 64MB partitons I think you’ve reached the end of the line with this drive.

If you have access to a Linux system’s Terminal service try nuking it with:

parted /dev/sd X
mklabel msdos
quit

where X is the device id of the USB drive.

Then partition it using GParted.

Nope, still 2x64. Actually, it’s one 64MB drive, but system sees two. Only one formats successfully, the other one is cloned when device reconnects. Well, I guess this is it. Cost $80, broke just after warranty ended. Thank you, SanDisk :neutral_face:

On a positive note, a new 16GB drive will cost a whole lot less.

You could still try returning it to SanDisk and see if they replace it.