16gb card stuttering ,8gb card ok!!

ive got a 16gb sandisk class 2 card in my fuse and most songs stutter.i put a 8gb class 4 in and this was ok

any ideas?

ive flashed the latest firmwear

Could be a bad card.

Are they the exact same files that play on the other card? Can you play them from the card on your computer through a card reader?

Try running Error-checking on the card. In Windows Explorer, right-click on the card, Properties/Tools/Error-Checking.

Also, there are counterfeit cards out there. You might try h2testw on the card to see if it’s good.

the 16gb card has been checked and is fine.now the funny thing .my sansa fuze is a v1 with the latest firmware ,my sons is a v2 and the card works fine in his!!i also tried loading rockbox firmware on mine and the card was fine!!i dont like rockbox though to be fair

Very strange. You could try rolling back the firmware to an earlier version, with the steps in this post.

The stuttering you hear could be caused by a simple formatting problem.

Here’s a great utility for formatting SD/ SDHC  cards properly, the SD card formatter

If you have a stutter on one card, and others play fine, the problem might just be in the details.  I see you have two different revision Fuzes as well; the v2 has integrated SDRAM that reduces processor overhead.  As flash memory has become more affordable, and the capacity has simply blossomed, it’s easy to miss some of the little details behind large capacity memory.

When you format a memory device, you are marking the memory locations as available.  There’s a master index that tells the computer, or the Fuze in this case, just where the data is stored.  This is the FAT, the file allocation table.  As the device reads each cluster of data, the table tells the device where to find the next one.  When playing back a music or video file, this can be a big task, as each cluster is read into memory for playback, after decoding.

When you use the format command on the Sansa, it only formats the internal memory, not the microSD card.  I will bet that that 16GB microSD has a huge FAT, quite possibly with Windows’ default favorite, 4kb clusters.  Locating the teeny clusters requires a lot of processor time.

Ideally, the Sansa needs 32kb cluster allocation , as this size is optimal for the device, requiring considerably less processor time.  You’ll hear the “chops” in playback as the little guy struggles with that huge list.

Connect the Fuze in MSC mode (Settings > System Settings > USB mode > MSC).  Plug in to your PC, and let’s have a look using the chkdsk utility

First, let’s find out how windows sees the Fuze.  Click on My Computer for a Windows Explorer window, and look for the drive letters assigned to the Fuze, with the 16GB card installed.  The first letter is the internal memory, and the second is the card.  You can click on this drive and select Properties to verify it’s the 16GB device.

Click on Start, and in the Run box, enter cmd, and press Enter.  You will get a handy DOS window.  Welcome to the Matrix.  Enter chkdsk x: where X is the drive letter you found for the microSD card.  The line you’re looking for is the one referring to allocation cluster size.  I’ll bet you have something around that magical 4kb size.

Close the window, and you can then format the 16GB card with 32kb clusters , which will solve your annoying stutter!  Of course, it will clear the existing data from the card, so you’ll have to reload, but the reward is no more annoying stutter.

If you choose Format in WIndows, first choose FAT32, then 32kb as your cluster size.

Bob  :smileyvery-happy:

Hi,thanks for the detailed reply.i ran checkdisk and the cluster size was already 32kb .

any ideas ?

ive tried rockbox firmware and the 16gb card works fine!!(changed back to the sandisk firmware as i dont like rockbox)

OK, this is probably completely irrelevant, but when I got stuttering files on the Fuze, I tried every software fix i could think of. And the problem was that the headphone wasn’t all the way in the jack. I know it seems to only happen on this card but…give the jack an extra twist as you put it in anyway.

Yeah, that probably wasn’t it. So:

Just for the heck of it, format it one more time via Windows Explorer to FAT32. It can’t hurt (though it will erase your files). A manual reload of the latest firmware wouldn’t hurt either.

Since Rockbox reads it, the slot is working, so it’s apparently not a hardware problem. And since the same files work from the 8GB, it doesn’t seem connected to the files. So maybe it’s some quirk from the last time you formatted.

I’ve got a 16gB class 2 card in mine, and while I’m not playing such large files, I haven’t had any problems with stuttering.

However, every so often–like every 5-6 months–the Fuze suddenly  freezes while trying to read the card. When I take out the card, it’s fine. The solution, which makes no sense but works, is to leave out the card and run the Fuze’s own Format (Settings/System Settings/Format) on the internal memory (after backing up everything of course). So you might try that as well.

But your problem does seem resistant to typical troubleshooting.

Simple Question: have you tried defragging the card? Maybe that will help, but I can’t guarantee it.

@halonachos117 wrote:

Simple Question: have you tried defragging the card? Maybe that will help, but I can’t guarantee it.

De-fragging flash memory does more harm than good. A spinning physical hard drive is another story, and will benefit from de-fragging.