Won't copy video from flash to camera roll

Trying to copy a video (1.4Gb) from te flash drive to my iPhone.

It starts, copies, completes. I close app, goto camera roll and it’s not there, goto app and nt there either, it’s an MP4 file and streams fine.

I then tried another video which was 600Mb and this copies over fine and appeared in my camera roll.

So is there a limit on file size? Or is it a limit on the iPhone camera roll or something.

Also I noticed my iPhone got really warm on the back when doing this transfer and it sucks the battery, takes maybe 5mins to copy over.

When a file is coppied from the WFD to an iOS device it is first copied to the downloads folder within the WFD app then it is copied to the camera roll. iOS may be leaving the copy in both places before it is deleted from the download folder so you may essentially need twice as much free space as the size of the file. How much free space do you have on the iphone?

Ah I see, I dont have 3Gb free, I only had about 1.7Gb free.

The touble is it went through the whole prcess of the copy, took a while, (iPhone got really warm), and then when hot close, it just wasnt there, and I had the same remaining space I had before I tried to copy it in.

Trying to copy videoes wireless from an app on my iphone4 for storage to the sandisk