Wireless stick continuously disconnects on USB


i have a sandisk connect wireless stick, 16 GB, and for some reason it continuously disconnects from my computer then reconnects- as long as i have the stick plugged into usb it will continue to do this.

i think i’ve narroved it down to some sort of idle timeout issue, becuase as long as i continue to make changes on the drive (for example, create folders or remove them), the drive stays connected- if i don’t do anything on the drive it will eventually disconnect after about 1 minute (ie, disappear from My Computer) then will reconnect seconds later.  it seems to disconnect after 1 minute of inactivity.

can anyone help with this?  i’ve disabled power savings mode on the stick and changed the wifi channel a few times as suggested in the article below but no success… and i’m pretty sure this is an issue with the stick because i use many other usb flash drives (and external) and have not had this issue with any of them.

i would try updating the firmware but becuase of the disconnect issue, i’m afriad the upgrade process won’t have enough time to complete and botch the device.



what operating system are you using? do any other USB drives work normally on the same computer? does the wireless stick work normally on other computers? What is the OS on the other computers where the drive has been tested?

windows 10, yes other usb drives work fine on the same computer (both flash and external), stick has the same behaviour on another computer, also windows 10.

Also what FW version are you running? I did a quick test with my wireless stick and Windows 10 creators update and it is working. how long do you have it plugged in before you see it disconnect?

do you have creators update? if not do you plan on installing the update? do you have any other OS than windows 10 to see if the issue is there as well? 

the issue could be with the drive itself. You can verify by testing with a different OS. If the issue occurs with other OS then the drive is proabbly bad and would need to be replaced. If the issue only occurs with a specific OS it could be OS related. 

it’s an older version of the firmware, 3.x i think… disconnects after about 1 minute.

i don’t have creator update yet or another os to test on… is it safe to say that this behaviour is not by design?  this isn’t a setting out of the box that can be changed somewhere?

no not by design for sure. I would definitely try getting to a computer where you can do the FW update. if that does not help the issue you may want to update the PC to creator update and see if that helps. 

one thing i just thought of- i had the stick connected via usb to the console of my electronic drum kit for awhile, essentially allows play along with audio files that are saved on the stick- i don’t recall any issues using the stick with that setup, and pretty sure all the songs are longer than 1 minute.  so theoretically in that environment the device disconnects do not appear to be an issue- not sure how the drum kit console is confgured interface/OS wise though…

So I tried the firmware upgrade with no success. I plugged the stick into another Windows 10 computer and it stayed connected for several minutes before disconnecting.

I was able to drag the firmware update file to the root of the drive and then Eject from the computer, but the update process didn’t start, and I left the stick connected for several minutes. I also disconnected the stick to see if the update process would start… am I doing the update process correctly? Seems odd that nothing would happen…

Are you ejecting the drive or just disconnecting it? The drive has to be ejected for the FW update to initiate. 


  1. Turn the Wireless Stick off
  2. Connect the Wireless Stick  to a computer via USB
  3. Drag the update file onto the Drive. Make sure to put it in the root or main directory and not in a sub folder.
    4. Right Click the removable disk and select Eject.

On a Windows Computer, go to My Computer, right-click on the Wireless Stick, then choose Eject.

On a Mac computer, find the Wireless Stick on your desktop and right-click on it, then choose Eject.

yes, i’ve followed these steps many times… are you supposed to leave the sticked plugged in after ejecting?  i’ve done this and also tried unplugging (as suggested in the kb article) but the firmware upgrade did not start.

using the iOS or android app in settings what FW version does it say you have?

Android app shows 3.4.2 (A02S 1105)

Hi guys,

I have the same problem & I think it started after last Windsows 10 creators edition update (Windows Home x64).

I own a Sandisk Connect Wireless Flash Drive 32GB (with the latest firmware) which after insertion to any USB port keeps connecting & disconnecting every 5-10 secs.

It works just fine to my laptop which doesn’t have the Creators edirtion.

The USB ports works with any other USB device (external drives, flash drives, printers).

The SanDisk drive although it appears & disappears from device manager (every 5-10 secs) it never appears to My Computer devices (File Explorer), so I can’t perform any operation with it.

I reinstalled the latest firmware update & formatted the flash disk using my laptop but the problem remains.

My motherboard is a Asus Crosshair II with nVidia nForce 780a SLI chipset.

There are no chipset drivers for Windows 10 to re-install just in case something went wrong with the USB drivers during Creators edition update.

Any ideas?

my issue is a little different- i do not have the Windows 10 creators update and my device does appear under My Computer so i am able to access the data on the device.


You are right! Sandisk flash drive does the same thing on my laptop as yours but at least it is functional!

On the contrary, on my desktop PC whic runs Creators Edition doesn’t appear at all on File Explorer. Not functional!

Keep googling…

FW version 3.4.2 is a Wireless Flash Drive not a Wireless Stick. The Wireless Flash Drive is the older now obsolete version of the Connect product line. I contacted SanDisk support and there is a computability’s issue with the latest Windows 10 creators update. This issue will unfortunately not be fixed as the Wireless Flash Drive is an obsolete product and only officially supports up to Windows 8.  

thanks, i bought a wireless stick, didn’t realize the flash drive was that old… does the stick allow wireless access while it’s connected to a usb port?  ie, can you have it plugged into a computer and add/remove files wirelessly at the same time?

no the controller only supports a single access to the memory at a time. either MSC or wireless. You can connect it to a ac charger and charge it and also connect wirelessly but if it is connected to a computer it mounts as MSC and you cannot connect wirelessly. 

I’ve just come back to use my 64GB wireless connect after a few months, it appears to have charge in it but I’m not convinced. I also am having the same problem with it dropping off USB. On my personal windows 10 creators machine (core I5 vaio trying in both USB2 and USB3 ports) it is detected and “ejects” before I can even interrogate it.

I’ve brought it into work to test on a Lenovo thinkpad also windows 10 but not creators, and it is visible but after 10-15 minutes it “ejects” itself and then a few minutes later redetects and opens in explorer.

I tried it in the PC as it was consistently dropping connections with my phone on wireless, but as I have a new phone I’m not sure that was connected.

I’ve had the device a coupel of years now and up until this occasion it’s been fine every time I’ve used it. My last use was on my older phone about 4 months ago.

if you have had it for a few years you probably have the older version the Wireless Flash Drive. 


If this is the drive you have it is not compatible with Win 10. Only officailly supported up to 8. There is a new version of this drive the Wireless Stick. It is compatible with Win 10.