Windows Media Player encountered a problem...

“Windows Media Player encountered a problem while synchronizing the file to the device. For additional assistance click web help.”

That is the latest error I’m getting. Microsoft’s web site then says: You’ve encountered error message C00D1236 while using Windows Media Player. Cannot sync the file.

So, what led up to that is:

  1. had problems with the device for a long time.

  2. Finally investigated and found the lastest firmware and updated the device. This fixed some problems, which is great, but caused worse problems.

  3. I was getting: “Windows Media Player cannot access the file. The file might be in use, you might not have access to the computer where the file is stored, or your proxy settings might not be correct.” on several random files. It would do that and then if I wiped everything out and tried again, it might do that with different files. It was also taking a long time between files while syncing. So, I found this post: and formatted with Windows Media Player. (I’ve now formated every possible way I think.) Sure enough, it fixed that. The problem files synced right away, but then nearly all my other files failed to sync giving the most recent error.

A. By the way, the playlist does not work. Even if I get the playlist on the device, there are no songs in it. The songs/podcasts are only available via other classifications.

B. Having installed the firmware update program, there’s now some remnant resident program which dies when I plug in my Clip. “Universal firmware updater for Sandisk Sansa MP3 players has stopped working.” I can disable/uninstall that program, but it’s just another problem. I am running Vista with all the latest patches.

Any help? Need to be able to sync all files and have the playlists work right.

Are all the files you’re syncing still playing on your computer? You might have overlooked that as the cause of the error. For playlist to sync properly using Windows Media Player, make sure you are on MTP mode.

If syncing causes issues and those songs you have are not licensed I would suggest drag and drop in MSC. Solves most of the forumers problems with errors and such using Windows Media Player. 

Thanks for the reply. The problem is definitely not with the files.

I think I got confused and thought I needed it in MSC mode, but I think it was originally working right in MTP mode. 

So, the last time I tried in MSC mode, everything synced fine, though playlists didn’t work and I didn’t try filling it up; so maybe more files would have caused a problem.

So, I switched to MTP mode and dragged over the same playlists and it got about 2/3 of the way through the list then gave errors on two files, paused for a while then gave up saying stopped in the status for the rest.

The playlist that completed is in the device and seems to work.

So, maybe I could switch to MSC mode and get the files on there, but I want to keep track of what I’ve listened to and put things in a certain order, hense the playlists. I’ll try fiddling with Windows Media Player or something.

Aha! I think I figured it out. I deleted all the files in the AppData\Local\Microsoft\Media Player\Transcoded Files Cache and now everything is syncing again.

It still does this weird thing again. When the screen is black and I’m listening to something, if I hit the control ring, like hit up for example, the screen does not necessarily come back on. I guess I should start another thread for that. It seems that there are different features that work better or worse depending on the USB mode. I never knew there was such a thing before this problem.

Good to see it ressolve and that information can be usefull to others. Thanks for sharing!

2nd concern, try the scroll wheel. Or press another button. That should light it up. 

I don’t think it matters whether the unit is in MSC or MTP mode when playing, but you should not mix modes. If you do, you will eventually run into problems including not remembering what you did in what mode.

I always use MSC mode and drag and drop. For a test I loaded one album in MTP mode. Later I wanted to work with that album and couldn’t access it and I’d forgotten how it got there. I switched to my test system which has latest WMP, used that to delete the album and noticed there were some other file I never knew were there - probably test files that came with the unit so I got rid of those also.They must have been in an album I hadn’t noticed.

Hopefully, that’s the last time I’ll use either MTP mode or WMP. If I had to use MTP I would probably opt for Rhapsody. This has an itunes look and feel and while I know this is heresy, the Apple stuff does work well. If I wanted Playlists in MSC mode, winamp works well.

Ok, well, yes choose a mode. And, I’m not sure if the hardware is glitchy or what, but it has actually been working fine once again for a few days.