Why not to use secure access vault

After I had saved hundreds of GB of files in the vault I tried to access them again. When opening the vault I could not sign in but was asked to enter a new password. Was strange to me but I didn’t have another option so on I went. As I still couldn’t manage to open the files, of which I could see the encrypted version all the time, I contacted support. This is what they said:

Support.: Hello. Thank you for contacting SanDisk®. I’ll be your Customer Care Specialist for today. One moment while I look into your question.
Nicolas : Yes sure, thanks
Support.: Which SanDisk SSD are you using ?
Nicolas: sandisk extreme portable ssd 1TB
Support.: What is the make and model of your host computer?
Nicolas: my computer is Lenovo Yoga 700 - 14 ISK and disc is SDSSDE60-1T00
Support.: It is very rare issue, when the SecureAccess asked you to setup a new account.
Support.: In this case, I would suggest you to delete the settings folder and then try to access the drive with your old password.
Nicolas: So I delete “SandiskSecureAccess Settings” Folder?
Nicolas: and then try to sign in again?
Support.: Yes, with the old password/
Nicolas: I deleted the folder but it didn’t change anything. I an’t sign in with the old password but it works with the new password
Nicolas: however I still don’t see all the files from the SanDiskSecureAccess Vault folder (351GB)
Nicolas: I have also tried to drag and drop SanDiskSecureAccess Vault onto SanDiskSecureAccessV3_win
Support.: ohh, I am sorry to inform you but inthat case your data is lost.
Nicolas: It then says Open With SanDiskSecureAccessV3_win and when I drop I can sign in with my new password but then the files are not opened
Nicolas: Well that’s a shame for 351GB of data…
Nicolas: Does that mean I should better not use the Sandisk Vault anymore?
Nicolas: Or how can I avoid losing hundreds of GB’s of data again?
Support.: Never setup a new account, when you already have one.
Support.: Is there anything else, I may assist you with?
Nicolas: but how can I log in to my old account if the only option the program gives me is to set up a new account?
Nicolas: how can I reset the program?
Nicolas: I did not chose to set up a new account
Support.: I understand it was given to you. But cancel the prompt and open again.
Nicolas: hmmmm ok… I just can’t believe that setting up a second account completely destroyed 351 GBs of data and there’s nothing the support of the program can do to get them back, even if all of the encrypted files are still there
Nicolas: This is just really frustrating
Support.: I sincerely apologize for the inconvenience caused.
Support.: But in this case, data cannot be retrived,
Nicolas: Well I accept the appology and I am aware it is not your personal fault and it is not a nice position to be in as an employee of customer support. But I do hope you report this issue to the development department so they can fix this because this really must not happen. This is where people put their most important and confidential documents that might have a huge impact on a lot of peoples lives, so please take this seriously.
Support: Thank you for feedback !
Support: Is there anything else, I may assist you with?
after 1 min without response, after I had waited a long time
Support: We are not getting any response from your end, please acknowledge or we will disconnect the chat.
Support: As we are not getting any response from your end, SanDisk is disconnecting this chat. If your issue still persists please contact us again. Thank you for contacting SanDisk , and you have a great day, Nicolas.
Support has disconnected.

What a disappointment Sandisk
So please people, don’t secure your important documents in there, you might just lose them and nobody will get them back for you.
Be smarter than I was