When I release power button the player turns off

Hi there,

I’ve been using my Sansa for quite a long time, today I faced this problem, when I try to turn on the player actually turns on, appears the loading screen of rockbox and the menu but when I release the power button it turns off.

I’ve tried to connect it via usb cable to my laptop but the same thing happens, after 30 seconds more or less it turns off by itself.

I’ve also tried to charge it with my phone’s charger and yet the same thing happens.

It’s not a battery problem 'cause the battery is full loaded.

Already did the reset by holding the power button, but as I said if I hold the power button it will turn on and off even if I keep pressing the button.

Hope everything’s clear, hope someone can help me, thanks in advance.

First, we need to know exactly which model your sansa is, as they behave slightly differently.

Second question, Rockbox is installed?

Rockbox makes the dilemma a little quirky, though I am sure there are plenty of Clip with Rockbox users here that may help. Have you tried performing a reset on the device by holding the power button depressed for 30 seconds, release the button, then see if it starts up normally.

The boot process with Rockbox may be a little different, as it’s “inserted” into the boot process. Have you tried seeing if the device can be switched into regular Sansa operation, and will remain running?

If you plug the device in to the USB port, does the device show up on the computer as normal?


Its a little unclear, but it sounds like he means that device will do the hard power off if he doesn’t press the power button. Maybe its a stuck button? So that its basically held down all the time unless he pushes on it a little?

Thank you for the replies, the model is Sansa Clip Zip, this one.

Rockbox is istalled, I’ve been using the player with Rockbox for more than a year and had no problem at all.

I’ve tried to reset the device by holdin the power button even for 1 minute, but nothing happened (the device turns on and then turns off)

If I plug the device in the USB port it turns on, I can access the folders in the computer but after 30 seconds or less it turns off and the device is not shown anymore in the computer as if it was unplugged.

I’ve uploaded a video for clarify the situation


Sounds like a hardware failure. Probably no way to fix it; get another (under warranty if applicable).