VBR mp3 skipping/stuttering on 8GB model

Hi there,

I have an 8GB Sansa Fuze and with some VBR mp3 files I get serious skipping/stuttering of playback, especially when the backlight goes off. It seems similar to the audio-book problem in another post, and I was suspicious it was caused by the mp3s being VBR.

I have converted a song that suffered from particularly stuttered playback into 128kbps CBR and this resulted in no stuttering. Suspecting file-size (as the VBR was 9.7MB) I took the same original VBR file and converted it to 320kbps CBR, and again no stuttering.

Hopefully there is a fix coming?

Cheers,

Andrew

Further to the above - no uSD cards involoved, and I havn’t formatted the player or anything since it was purchased brand-new - it still even has the free supplied music on it.

Message Edited by DukePacman on 08-09-2008 12:32 PM

Thanks for the heads-up regarding your issue.

Don’t worry, as the issue is being looked at, and playback issues are on the front burner.  The new processor family for the Fuze does some really cool things, and I’m sure that the team is spending a lot of time with the earbuds on.

With that thought, I had better run on to a few tasks at hand, starting with coffee.  I’ve had some issues with decoding on my trusty specimens here as well.

The next firmware release is coming up too. 

Bob  :smileyvery-happy: 

Can you tell us the VBR file bit rate range ?  Also can test with a higher minimum VBR rate?

Hi - I’ can’t easily tell you the range as I haven’t found a tool I’m happy with yet - perhaps I can send you the file?

If you want me to try playing a file with a higher min VBR perhaps you can email it to me?

Cheers,

Andrew 

@dukepacman wrote:

 

Hi - I’ can’t easily tell you the range as I haven’t found a tool I’m happy with yet - perhaps I can send you the file?

 

If you want me to try playing a file with a higher min VBR perhaps you can email it to me?

 

Cheers,

Andrew 

Ha! Trying to wrangle free music, eh? :wink:

I’m curious as well as to the specs of your mp3 file. Any update about what the source of these vbr content were from? sampling rate, vbr rate, program used to encode?

You’re welcome to a copy of a problem VBR mp3 file - I don’t know of a single VBR mp3 I have that doesn’t cause the player to skip/stutter.

They have been created from original CDs, ripped using something like Sound Juicer with encoding by Lame (I’m a Linux user) with standard sample rate settings.

Cheers,

Andrew 

yes please post some link to your problem vbr. and what firmware your using.  Use some file share site like rapidshare, megaupload, etc. a few problem files would be fine.

Firmware v01.01.11A which I understnad is the latest/only available.

Stuttering is noticable when the backlight goes off.

Sample VBRs that cause problem:

1

2

3

4

i.e.

  1. http://rapidshare.com/files/150181755/01_-_Coldplay_-_A_Rush_of_Blood_to_the_Head_-_Politik.mp3.html

  2. http://rapidshare.com/files/150181756/01_-_Red_Hot_Chili_Peppers_-_Californication_-_Around_The_World.mp3.html

  3. http://rapidshare.com/files/150181757/01_-_U2_-_The_B-Sides_1980-1990_-_The_Three_Sunrises.mp3.html 

  4. http://rapidshare.com/files/150181758/7_-_Oh_My_Lord.mp3.html

Cheers,

Andrew 

Downloading as of now.  Thanks for the post, I’ll get back with you with the results.

Alright, you’ve got some interesting mp3s there, and I believe the issue is with Sound Juicer method of encoding. Looking at the bitrate activity, it remsembles that of ABR (ogg style). Although the bitrate is dynamic and is technically VBR, mp3’s encoded at VBR normally have a high and low bitrate that resembles the standard bitrates (64,96,128,160,192,256,320) and will jump between those states.  ABR on the other hand stays pretty stationary at irregular birates (your “around theworld” track averaged at around 200kbps). I’m guessing the Fuze doesn’t know how to handle decoding properly.

At the moment I suggest using Windows Media Player or CDEX (http://cdexos.sourceforge.net/?q=download) to extract your cds into CBR mp3, until a fix for Fuze comes out  (I think it might be soon?)

Goodluck!

I also have an 8GB Fuze and suffer from the ticks while listening to most of my mp3 files. I upgraded from a 2nd gen ipod two weeks ago and I am afraid I must say it hasn’t been a success so far. Mostly this is because of the inability to play mp3 files properly! On top of that, the podcast I listen to on my commute (http://feeds.nos.nl/MHOOM) suffers from the same stuttering.

The good news is that this morning I finally found a remedy. On my fuze the stuttering starts as soon as the screen saver blanks the screen. So now I have the brightness set to its lowest and the screen saver timeout to one hour. Though this still drains the battery and now at the end of the day my battery was flat.

Sansa, could you please fix this in the next release?

Thanks, Floone.

floone-

Transfer your podcasts in a constant bitrate, to minimize decoding issues.  (I haven’t sampled your file as yet.)

Be sure to have a backup copy of your music, as formatting the device will erase all media from the device.

ON THE FUZE, format the memory using the onboard format command:

Settings > System Settings > Format > Yes.  The Fuze will clear the memory, and build a tasty file allocation table with optimized 32KB blocks.  Windows likes wee 4KB blocks, and the resulting huge table means that the Fuze is busy locating your media’s data.  The resulting clicking sound will usually start at the 50 percent point of a file longer than 8 minutes.

An interesting characteristic found is that the sound decreases when the display is illuminated, probably because the device is busy with a separate task.

The device can be formatted from Windows if you set the allocation size to 32KB.

Reload your files, and enjoy a pop-free sound!

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 10-13-2008 01:13 PM

Thank you for the quick reply. As it is a new player I have no problem with re-loading my music. I am using MediaMonkey and am not sure though if it is possible to send the podcast to my fuze in a different bit rate. If I have to re-sample them myself that would be too much work to do in the morning (I am still waiting for the first mp3 manufacturer who comes up with a still-to-invent small network plug on their player so I can connect the player to my router over-night and have it loaded with my podcast subscriptions and charged when I wake up. And no, I do not want wifi as it drains battery and I am too green to leave the wifi on when not in use - if you invent this new network plug, can I have royalties please :wink:).

Though I still think the problem is the screen saver, as quite a lot of my music files also have this problem - and on my player as soon as the screen goes black from the screensaver the clicking starts.

I had a listen to the podcast.  Het is aardig om het Nederlands te horen.  I hope that is correct, as my father spoke Dutch to me when I was a wee lad.  I love the familiar sound, and my grandmother’s fried balkenbrij on hard bread with bean soup.

The sound you hear can be solved by formatting the device in FAT32 with the allocation block size set to 32KB.  The easiest way to do this is simply use the Fuze’s format command.  With the correct (optimized) memory block size, the noise will go away.  The affect of the display is actually a separate issue that masks the sound.

For podcasts, you can indeed do this.  Load and install the Juice Podcast receiver and set it to capture your daily podcasts.  I believe Media Monkey also has a podcast aggregator built in as well, that will send your feeds automatically to the device.

I am not running Media Monkey- perhaps someone using the application can enlighten us about the podcast feature with MM.

Bob  :smileyvery-happy:

Dutch indeed, and your Dutch is still OK!

Thanks for the advise, I am going to do this tonight. Podcasts on MediaMonkey work indeed fine with the Fuze. I also need to format mu sd card I suppose, but should be able to Google out how to do that.

Bob, thank you very much for your help and quick replies!

Floone

I couldn’t wait this morning to see my fuze working this morning so I skipper breakfast and took the time to format the player using the menu option on the fuze. This was remarkable quick by the way. Then I copied last night podcast and re-set the screensaver from 1 hour to 15 secs. I also checked the format of the drive in Explorer and it said FAT32, though it doesn’t show the block size. Unfortunately the problem is still there; as soon as the screen saver blacks the screen the player starts stuttering. Anybody else has the same problem? Could it be a hardware issue (i.e. do I have a faulty player)?

Thanks for you help,

Floone

Its not a faulty player.  its a software problem and we are working on a solution.  We are hoping to have this fixed in the next release.

Cheers, 

SansaFix

Bob,

Just a thought on the effect and possible cause of the screen brightness effecting the sound…  I’m just putting two and two together and trying to come up 4…  I wonder if this effect is similar to the effect that i get on my LCD TV 37"and 46"…On both my sets when I lower the back light I get a audible hum in the sound, faint but there…  At least on my set I believe the fluorescent lamps don’t like to be regulated…  At least not in the manner Vizio uses… This is just a passing thought!!  George

 VBR files are tricking the software to set a low default clock speed and when the songs bit rate increases the clock setting is insufficient with backlight off.

 When the backlight is on,  the clock rate is increased.  So the song plays without stuttering.

Hope that helps.