Vault files on SanDisk are gone after 'repair' (please help)

Hello everyone.

Recently, I was adding files into the Vault of my SanDisk Cruzer 64 GB when all of a sudden, the files I was trying to add was too large and I ran out of space. I got an error message but I don’t remember what it said. Regardless, I tried to enter back into the Vault later and got this message:

“This vault could not be loaded, it may be located on another computer or the original vault has been manually removed”

Unsure what to do, I went to the properties tab on the Vault and clicked to repair. It repaired whatever was causing it issues but when I went to check the Vault most of my files were deleted. The only files which were not deleted were files from a year ago, but all my photos and videos (which were highly sentimental) were gone.

When I go into the Vault it says there is 9 GB out of 59 GB left. However, when I go into the Windows window and click properties of the actual USB stick, it says there is only 800 KB remaining, and that it is basically entirely full (59 GB out of 59 GB). Thus, I think the files should still be there (albeit encrypted) but when I enter the Vault after entering my password I cannot see them.

Does anybody have any suggestions? I’m not sure what to do and I would hate to lose these photos. I’m not sure if SanDisk has a phone I can call but I’m going to do that tomorrow (as it is late), but if anybody knows what I can do I would be most appreciative to hear it.

Thank you.

This is the process I originally did to ‘remove’ the other files to begin with. However, I never deleted the files in the Vault. In my USB (under properties) it still says that the USB is almost entirely full (with 800 KB left).

If you look at your USB drive with Windows File Manager it should show you all the files and folders on it. If they are all SecureAccess folders and files that would confirm your suspicions that the vault is occupying all the drive.

A Windows function to repair allocation errors and etc might help you. In a Command Prompt window run a CHKDSK /F command for the drive letter assigned to the USB drive. Something like CHKDSK /F G: where G: is the drive letter of your USB drive. When it completes use the Windows’ Safe Remove function to remove the USB drive.

I would suggest rebooting at that point and once up retry using the USB drive.

If you are still having problems this link may help you.

Good luck.

I fixed the problem.

What ed_p said did not work in my particular situation, however, what the problem was was that since the USB was full on memory, something about trying to do what I did here originally (SecureAccess V3 Repair Vault Feature) caused the problem.

SOLUTION: What I did was I freed some space on my USB drive. Since I had both files I needed to store on my USB and the Vault files + program. By having some extra space (even like 30 MB helped compared to what it was at 800 KB), allowed me to enter into the Vault and do this again (SecureAccess V3 Repair Vault Feature). While this originally caused the problem, by freeing some space on my USB the repair function allowed it to repair itself and the files were back on the Vault (like anew again).

Just a heads up, repairing it (when the problem occured) lasted about 30 seconds, however, repairing it a second time (with extra space) lasted about 3 minutes. If it seems to be taking a few extra minutes to repair, it looks like it is working right. I hope it works for you too!

I do want to mention a thanks to ed_p. I don’t know who you are, but I appreciate you taking the time to try to help a complete stranger out, thank you kindly!!!

Thank you for the update gg. Especially good to hear you solved your problem.

An additional step you should consider for your important files, create a backup of them on a different drive. It won’t prevent future problems but it will reduce the stress they can cause. :slightly_smiling_face:

Lesson learned for sure lol. Thanks again :slight_smile: