Using Internet Connection stops password recognition

When I set up my WFD to use the internet connection while on my WFD, next time I try to sign on it does not recognize my password. I had to restoWFD to original setting, and NOT use the internet connection, or it happens again. Is this a general problem…or just with me? (Ipad 2)

I have never had any similar issue. Exactly what steps are you taking? 

I set up the WFD per the instructions to use the internet while using the WFD. Once I do that, however, I can no l,onger access the WFD, and must do a reset to remove the internet connection.

I have experienced a similar situation, also with the iPad 2.
First time it worked, I followed the provided instructions and I had the WFD working with the internet connection as described in the manual.
The following day I started the WFD but it did not come up in the app as connected to the iPad. The WFD was flashing the blue light twice, meaning it had an internet connection. However I have not been able anymore to connect to the WFD through the network, not even after resetting the WFD to the default settings.
I would also appreciate some help

I have a similar issue. i am not able to use internet while connected to sandisk connect.

i tried all the steps as described, i even tried the settings with different wireless networks and different android devices but failed.most of the times either the disk does not reconise wifi network and on one or two occassions when it did recognise a network it failed to save it as preffered network.

i need some urgent help as i cannot survive without being connected to internet because of job issues.