usb flash drive capacity lost after using winToUSB program

i have a SanDisk Cruzer Blade usb flash drive, and it had 32gb capacity. i installed windows 7 on it using winToUSB program. now i want to use it for other things instead, but it has only 14gb maximum capacity. I tried to mess around in disk managment, i tried to “delete volume” and create a new partition.

i followed this guide to the letter:

in that guide u basically use diskpart to create a new and clean partition.

after everything, i still have only 14gb. please help me restore the full capacity of this drive.

Have you tried writing to the WinToUSB creator and asking him what to do? 

yes, and they cant (or wont) help me. but isn’t there a way to restore the flash drive to its original state?

diskpart clean should remove all partitions from the drive and set it back to the original. if that is not working that usually is not a good sign. 

there is an app called HP Disk Storage Format Tool. Google search for that and see if it will restore the full capacity. If that does not work and diskpart is not working you may be out of luck. 

HP Disk Storage Format Tool says the disk is write protected, even tho i unprotected it via diskpart.

the drive may be bricked in that case.