"USB Device Removed" message when I connect dual flash drive to my phone

I have a SanDisk 64GB dual flash drive I had no problems with it up until recently. I borrowed it to a friend and he somehow screwed it up by creating an unused partition on it and I had to reformat it.  Now when I plug the micro side into my phone I get the message “USB Device Removed” even though I am mounting it not removing it.

I have tried reformatting to both exFAT and FAT32 and get the same message with both when connecting it to my phone.  I have tried restarting my phone with the drive connected with both exFAT and FAT32 with no luck still.  My phone is a Moto G and the flash drive worked perfectly with it before.  I am now at a complete loss of what to do next.


in that case i would recommend formatting the drive with the computer using the disk managment where you can see also the partitions of the drive. if you are sure that there is no other partition on the drive you can format it with FAT32 and try it again on the phone to see if it is detected normally. 

if that also does not help, then you can contact the support of sandisk to see if they can provide you some more steps that you can try with the drive. 

you can contact them through this link