Updated iOS app tried to update ixpand drive but FAILED

I updated to the latest iOS iXpand app and there was a firmware upgrade available. I accepted the firmware upgrade and after a brief period, I recieved a message stating the the firmware upgrade failed. I tried restarting the phone and plugging in the ixpand in to the iphone but nothing. The green light on the side of the ixpand keeps blinking but nothing happens. 

The drive is detected via the USB port on both mac and windows. I have also tried reformatting the drive with the HP format application that was recommended by Sandisk. I deleted the iOS app and reinstalled it and my drive STILL is not being detected!

Please help me fix this issue and start using my drive again.




Thats a very interesting case and im sure that Sandisk would love to hear about this issue because its a brand new product and the firmware is posted now for 2 days.

Please take some time to copy your notes and send an email to the support of Sandisk.

I had this exact same thing happen.  Any progress figuring out a solution?

I have just had the same problem.

has there been a resolution to this?

The activity finally stops flashing but reconnecting the ixpand gives the same error - Firmware update failed!

if FW update is failing every time you attempt to update contact sandisk support. they may need to replace the ixpand.