Unable to stop Fuze from rapidly scrolling through songs on its own and freezing up - HELP

My son’s fuze started rapidly scrolling through is song list in numerical order, eventually.  He is unable to hear anything or stop it - any button pushing results in freezing.  We’ve tried the soft reset by turning off and on again.  We’ve plugged into the computer and it’s fully charged.  The Fuze is recognized when we sign in to Rhapsody and it shows that space has been used, but none of the downloaded songs are listed.

Any solutions?

One more thing - I just added a song from Rhapsody to see if that might jumpstart something.  The song shows up and plays perfectly, however now all the old music is nowhere to me found (when looking on the device or on the computer).  Space-wise, it still shows that the files are still there taking up room.  But, where are they?  Am I just going to have to reformat and reload EVERYTHING.  This would be the 2nd time he’s had to reload - this could get old :cry:

On the Fuze, go to Settings > System Settings > USB Mode > MTP.

Plug in and open the Rhapsody client.  The Fuze should show up in the sources pane on the left.

Log in to Rhapsody.  The bar display at the bottom of teh screen should show the client scanning and updating your track licenses.  If the licenses are expired, the Sansa will scroll forward through them without playing them.

Click on the Fuze after the scan is complete.  Look in the lower right corner of the client display.  Has the license date advanced to 30 days from the current date?


Tried it but it didn’t work. 

Yesterday when I logged into rhapsody I noticed the usual scan did not occur.  I clicked on the update track licenses yesterday (with no change), so the date advanced 30 from yesterday.  No tracks appeared.  The Fuze icon does appear on the left but no tracks are listed (only the 1 that I added last night).  However, it does say that 830.9 MB of space is being used.