Unable to restore C150 firmware

I have a Sansa C150 I want to start using again, but no Microsoft Windows XP machine available to me within 60 miles

I have removed the battery, locked the player (hold) and connected it to a Vista Ultimates machine (SP1), it boots to the ‘Sandisk’ splash screen - it stays there proceeding nowhere and it doesn’t appear in “Computer”

I have removed the battery, locked the player and connected it to the PC whilst it’s locked and held down the centre button. This time nothing appears on the player LCD but the PC makes the noise that something has been connected but the player doesn’t appear in ‘Computer’. However in Device Manager I now have an unknown device and I am asked if I want to install the drivers for this device. Of course I do and ask Microsoft to search it’s driver database for the appropriate software - it says NO ! and suggests I go to the manufactrurers web-site and search for them there.

Sandisk says NO ! But will allow me to download a  SansaUpdaterInstaller.exe file which I have done and tried that. It say, eventually, ‘now connect the device’ which I do but since the device isn’t recognised by Vista I get a message saying that there isn’t a Sansa installed (despite the beep beeps saying I have an unknown device connected)

How might one reflash the firmware if Vista hasn’t any generic drivers and Sandisk doesn’t have a transparent C150 Vista drivers download available ?

My c150 worked with vista-64 just fine after i figured it out.  it has to be set to ‘msc’ mode instead of ‘automatic’ and then it has to be turned on and the music paused before plugging in the usb cable.  follow these 2 steps and it shows up as “sansa c150” in “my computer” and you can move files to/from it, no problem.  hope that helps

That would be fantastic, except,

I’m trying to re-flash the firmware because the player isn’t responding as it did once.

The software on the player is corrupted which means that I can’t set it to ANY mode. The playerisn’t recognised by the computer, and yet the PC tries to install it as something, just not as an MP3 player or any removable device

thanks for the siuggestion but it doesn’t help

Ah, sorry, i didn’t read your original well enough to see that the unit had a problem in general and not just unable to connect to Vista.

I used the “Sansa Updater” software to update the firmware but it toasted my unit as well.  It just shows the Sandisk logo now.  I was hoping the firmware would fix the startup popping sound or something else useful but instead it is dead. :(  I haven’t heard from Sandisk support’s email yet.  I hope it can be recovered!

Good luck

Message Edited by magarity on 05-17-2009 11:11 PM

“I haven’t heard from Sandisk support’s email yet”

don’t hold your breath, in these harsh economic times the first casualty is customer support. It’s unprofitable and they’d much prefer you purchased a new device from them than try and repair that which you have already obtained.

There is a firmware flash for c140/c150 at wikibooks.org.  Follow the link at the bottom of the page.  Uncompress the .rar there are free programs that do this online.

that would be a good place to start

  • except there’s no link at the bottom of your post

and now, having found it, it says it’s for a C100, this shouldn’t be a problem because the device is now a (very light) paperweight

“I haven’t heard from Sandisk support’s email yet”

and I’m still waiting, I suspect that it may never arrive

took your advice, reset to MSC, and there it was, recognised at last…many thanks for your input…