Unable to re-partition 16GB Cruzer Titanium

Hi all.  I’ve got a 16GB Cruzer Titanium, hardware works fine.  Today while working on a Dell laptop issue I had downloaded Dell’s 32bit diagnosticcs untility which has an option to format a USB flash drive as a bootabl diag tool.  I proceeded to click the button to do this, everything else was automated.  The end result was a single 2GB FAT partition, the remaining space unparttioned.  

I did what I needed to do with the booting and diags, but now I’d like to revert this UFD back to normal, giving it the 16GB (14.9 usable) it had originally, then copy back the contents (including u3launch.exe) from my PC. 

Problem is, in Disk Management on any system here (XP Pro SP3 and Win7 Pro SP1 32bit), I am unable to Delete the partition, nor create a new partition out of the 12.9GB of unused space.  In short, I can do nothing except re-format (or copy data to/from) that initial 2GB FAT partition.  If I reformat as either FAT32 or NTFS, I’m still stuck with the 2GB partition with no apparent means of re-partitioning. 

Though ithe process wiped out the main U3 files on the readable partition itself, there still seems to be a 7MB CDFS hidden partition with the U3 boto code or what not on it.  Now, if I plug this blank UFD into my XP system, it autoplays and launches the little red Crozer icon that when clicked brings up the menu system with the Eject button and all that . On Win7 I get prompted to run u3launch.exe but ofcourse it’s gone so there’s an error that results.  Not sure if any of this info matters though. 

So basically I just need to clear the parittion(s) and make this device’s 14.9GB usable again.  Can anybody assist? 

" I had downloaded Dell’s 32bit diagnosticcs untility which has an option to format a USB flash drive as a bootabl diag tool."

Have you written to Dell about their utility and ask them how to reverse what it did?

" copy back the contents (including u3launch.exe) from my PC"

If it originally had U3 on it have you tried reinstalling U3 on it?  There’s a download link for it around here somewhere.

" there still seems to be a 7MB CDFS hidden partition with the U3 boto code or what not on it."

So the utility only wiped out the writable partition.  Ok, seems reasonable.  My writable U3 partitions are bootable while keeping the U3 CD partition.  BTW My U3 writable partitions are either FAT32 or NTFS.  Not sure why the Dell app made your’s FAT16, though it does offer the most booting compatibility.  The U3 CD partition launches the U3 menu but the apps are on the writable partition and since your’s got reformatted it explains the blank menu.  As for the Win 7 machine, make the LaunchU3.exe run in Vista SP2 compatibility mode if your Win 7 is 64bit.  That’s what I had to do, on my Win 7 32bit machine I believe U3 ran fine natively.

As for undoing the small partition reformat; try writing to Dell, try reinstalling U3, try a version of Linux. 

hth

Hi Ed, thanks for replying.

No contact with Dell yet.  The thinking was that it made more sense to write here first since regardless of whatever utility one might use to screw up the partitioning, the ability to reset things to normal would all be in one place, Sandisk.  Sandisk would have a sort of “master” utility or method to reset things like a low level format perhaps.  or rather, I’m sure they do but can someone not in their unit provisioning dept. get ahold of it, who knows :) 

I may contact Dell but I am sure I won’t get far with that - even if I get the actual programmer or dev team on the phone (highly unlikely but it’s the only way I’d get an answer on this issue) they’ll likely point the finiger to Sandisk and cite the fact that the Cruzers’ hidden parrtition is factoring in somehow.  Back and forth it would go I’m sure.  Call me cynical but I’ve got years of experience with these support boundaries and people doing their best to avoid having to take some responsibility whether or not the issue is theirs to begin with.  It’s a rare instance where someone vendures into the grey area, or middle-ground, between two vendor’s support boundaries and usually always the customer is the one left in the cold.  If this weren’t my first time dealing with a UFD issue I’d be inclined to just toss this unit in the trash and get a new one (it’s not worth spending hours fiddling with…), but since it is my first time I will see how far things can go. 

Regarding the stuff you mentioned, unless the u3 software has a partitioning utility in it then there’s little point in my concerning with that for now - the only thing I care really is about the inabiolity to fix the partioning.  The suggestion is appreciated though.  I don’t deal wkith Linux in my work so that doesn’t seem to be an option for me unfortunately.  Do you think a Knopix CD might suffice? 

I’ll try to keep positive so I do apologize for the sort of negative perspective I have coming across on this post :slight_smile:

Well, got my answer 2 minutes after my last post as to how far I’d get with Sandisk.  They do not support any form of partitioning on their devices.  Here’s their support statement:

http://kb.sandisk.com/app/answers/detail/a_id/231/kw/partition

So, I’ll give Dell a quick try and I do mean quick because I’ll likely just toss this UFD in about an hour if I don’t get some progress made.  But my question still stands about if you think Knopix might work (I’ve never used it, just know it exists).  Thanks again! 

FWIW

The U3 Launchpad has an option to remove U3 from the device, which inturn removes the CD partition, combines the space with the writable partition and reformats the new partition.  When installing the U3 software it reformats the writable partition, partitions the device to have a CD partition and writes the U3 apps System folder to the writable partition. So I would have to say it does indeed partition the device.  

As for partitioning removable devices as a whole, Windows doesn’t support it.  It only supports one partition.

I still don’t have my answer but for those who may read this post having the same issue, apparently the answer is to flip the “removable bit” to off so the OS will see the UFD as a fixed disk and allow partioning.  The only utility I can find referfence to so far that does this is Lexar USB Format, however I can’t find it for download from a reliable source (anything from the likes of filestube.com, more likely a trojan download than real file). 

"I still don’t have my answer "

Don’t you mean you may have one but refuse to try it?  :stuck_out_tongue:

Here’s another one you can refuse to try.  Download GParted, burn it to a CD, and run it.  Linux systems support partitioning removable devices.

Well, it really sucks that the original poster probably wont see this, but if you use diskpart from the windows command line, you can select the disk and use the command clean.

Open CMD (as administrator if need be). Type ‘diskpart’. After it comes up, type ‘list disk’. Identify which disk it is, then type ‘select disk *whichever#*’. after the disk is selected, type clean. your disk is now restored. Done this like 5 times today while experimenting to try to partition my Cruzer, which isnt working. But at least I was able to restore my flashdrive to full capacity. Hope this helps someone. God bless.

Thanks!!   That addressed my issue as well.  I was able to remove the partition data and then create a simple volumn and format it.
I was able to run the chkdsk utility on it and found no errors…  I was able to run the marching 1s and 0s diagnostic with any issues either.

Then I set up my isotoboot operation and looks like we have a winner!!

Thanks for providing this.

-d

use diskpart from the windows command line, you can select the disk and use the command clean.”

!!!  A very nice suggestion runeglen.  Thank you.

type ‘select disk *whichever#*’.”

Make very sure the *whichever#* is NOT 0.

Hi every on Fist of all i appolgise for the long infomation but pleas bare with me because some people may not know or understand.

PLEASE READ ALL THE INFORMATION DOWN BELOW BUT YOU ATEMPT ANYTHING !!

I have noticed that you all have some USB problems.

NOTE: I curently have a Sandisk Cruzer Switch with 15Gigs of storage and this method worked for me.

I [DO NOT] currently have a sandisk cruzer [TITANIUM]  but i think i may have a solution.

As you know USB’s, Hard Drives and SSD’s have to be patitioned for an [OPERATING SYSTEM] For Example Mac OSX, Windows or Other to be installed on or use for [STORAGE] or to[TRANSFER] any type of file/formats for example pictures, music and so on…

In this case the USB is used for many things but problems ocur when you have USB Device wich has a certain amount of Data capacity 15Gig for example and for some reason when you PLUG in your USB in to you LAPTOP or Mac and its says 5gigs of space remaining when originally you have 15gigs when you bought the USB device

=SOLUTION= down below

To Re-Partition your device

Visit this website: http://bbs.ipauly.com/viewtopic.php?f=2&t=2

HOW TO Re-Partition:

On windows=

1-> Go to download

2-> Click on the link MAKE SURE you get the updated version

2-> when downloaded Exract the ZIP file with extraction software WINRAR, or 7Zip

3-> Click on application

4-> RIGHT click and run as administartor

5-> Find a tab called [PARTS MANAGE]

6->Click on your USB then press [Re-Partition]

7->After press [USB-HDD mode (Single Partition) make sure you select [FAT32]

8-> Enter a Vol Label then finaly press ok, partition successful.

Note: if you have any files on you USB device i recomend to copy them to your computer/eExternal HDD or what ever as your files will be completely removed and UN-RECOVERABLE.

I WILL NOT BE RESPOSIBLE IF YOU LOOSE YOUR DATA I HAVE WARNED YOU.

I hoped this solution helped please reply if it was a successfull Re-Parttition.

Thank you Bmassey004…

Your Suport will be Apreciatable.

As you know USB’s, Hard Drives and SSD’s have to be patitioned for an [OPERATING SYSTEM]

a.  You’re 9 months late to the party.

b.  You’re statement is simply not true.  USB flash drives can be used immediately after purchased.  NO formating or partitioning required.