Unable to format my sandisk ultra usb 3.0 16gb pen drive


I have been using Sandisk Ultra usb 3.0 pen drive since Jan, 2016. I live in Mumbai. But previous month, I created bootable usb with mac os Mojave. Then I formatted pen drive. Dont know what happened, since then the pen drive is not appearing on the desktop screen. In the disk utility, the pendrive is showing but its main partition is faded out. In the info box, it is showing,  Mount Point: Not Mounted. I ran first aid, it is showing good condition. Then I clicked on mount in the diskutility selecting the faded out partition, nothing happened. 

when the faded out partition of the pendrive selected, I tried to erase with mac os journaled, it says, can not create file system on /dev/disk1s2 and below it, it was written ‘permission denied’ and at the bottom, it was written, file formatter failed. 

I tried to erase the disk with erase disk but no result, some error message is appearing. 

Please look into the picture for more details. 

Please guide me to get back the pen drive functioning properly. Thanks in advance.