Cant copy from Sandisk Ultra Dual Drive Go

Hi!

I have a Sandisk Ultra Dual Drive Go 256gb pendrive in an exFAT format. I unmounted after a copy task was completed and removed the file without noticing the pop-up of ‘Can’t unmount. Drive is busy’. Now I’m not able to copy any of the files from inside. Even browsing through the files makes the drive load and eventually ends up not working. I have some important files inside the drive. Is there any way I can back up the files before formatting?

With the drive plugged into your Windows machine open a Command Prompt window, with Admin privileges (right click) and try running a CHKDSK /F drvltr: command for the drive.:

Disk check is running till some percentage and gets stuck there. A pop up says Location is not available Drvltr:\ is not accessible Access is denied

It’s quite useless to complain and go after these. I have a Flash Drive 256 GB. It says write Protect. Unable to write to it. can open the folder/file. maybe i can copy the contents. tried removal of “Read Only” in the Properties. No help from the SanDisk even within the warranty period, thats why I said quite useless to go after these. May be anyone can use these pen drives as pendant. or key Chain.

sain the Access Denied sounds like a security problem. Although I’ve never heard of a security problem with a chkdsk command run as Admin. Very strange.

I tried the cmd mode. It didn’t recognise the drive. Couldn’t do anything. Just left it at that.

If the disk check stops and shows an “Access is denied” error, the drive seems to have serious problems. Here’s what you can do:

First try accessing the USB drive in Safe Mode. This can help identify any software conflicts that are causing problems. Also, consider replacing the USB port or using a different cable if there is a problem.

Next, check the license on the drive. Right-click it, select Properties, go to the Security tab, and make sure you have full access to your user account.

Another option is to boot your computer from a Linux Live USB. Ubuntu is a good choice. This can sometimes allow you to access drives that are inaccessible to Windows. Once you boot into Ubuntu, try logging in and copying your files.

If you still cannot retrieve the files, try using data recovery software such as Stellar Data Recovery software, Recuva, or Disk Dril. These tools can often recover files from even inaccessible drives.

If none of these methods work, it may be time to turn to professional data recovery professionals. They have the knowledge and tools to deal with more serious driving issues.