pendrive 32 gb

I formatted the pendrive and it deleted the sanDisk files which came in it already, after that pendrive didn’t worked . Is this due to files deletion which came in pendrive at time of purchase?

ALso what is the purpose of those sanDisk files which came in it ?

What do you mean the pendrive doesn’t work?  It doesn’t mount?  You can’t write to it?

The files on the drive are for SecureAccess which is the SanDisk app for encrypting files written to it.

I have exactly the same problem I have a brand new Sandisk Ultra USB3.0 32GB

Drive is listed as ReadOnly in the windows Disk Manager

Under Diskpart is shows ‘Current Read only State: yes’

But 'Read only: No

tried clearing attribute  btu it did not work.

In addition I tried using on a different debian PC - still only read only.

Anybody any ideas or have I got a dodgy drive?


Just noticed similar post going back to 2012and ongoing - seems like Sandisk  flash drives are ones to to avoid.

Yup.  Every 8 yrs they make a bad one.  Of course the counterfeit ones fail more frequently, but they don’t offer a free replacement like SanDisk does.