My sandisk ultra usb 3.0 is write protected what to do?

My new sandisk ultra usb 3.0 is write protected.
I tried to change it throgh command prompt ( attributes disk clean read only) but the issue is not solved

I tried to change it through regedit. But still issue is not solved.

I tried to change it through third party software. But it didn’t work.

Whatever I do, I can disable readonly but could not change Current read-only state to No.

Any help guys? What to do?

Hi @nredthry,

Please check mention below link article of Write Protect Error on USB Flash Drives:

Users need to file a class action lawsuit against Sandisk. This problem is solvable, but Sandisk refuses to fix it, because they’re making a ton of money off it.

1 Like

Disable write protection using command line (CMD)

  1. Connect your write protected SD card to your computer.
  2. Right Click on Start. …
  3. Type diskpart and hit Enter.
  4. Type list disk and hit Enter. …
  5. Type select disk . …
  6. Type attributes disk clear readonly and press Enter.

That didn’t work

If you still can’t remove the read-only of the drive, reformat it using diskpart or 3rd-party software,
or use a non-windows machine for reformating of drive to ensure the success of resetting drive/partition flags

Add to that:

  • clean
  • create partition primary
  • format fs=ntfs
  • exit

It will work!

Do NOT recommend the old ntfs format for USB drives. More writes, more wear, slows down the drive. For drives over 32 GB use format fs=exfat.

Immediate return, flash drives go write only when they fail.

I really don’t think any budget drives are fully burned in at the factory to test for defects, takes too long, often hours.

Always run the check flash tool on a new drive to fill and verify all the memory, it takes a long time.

If any errors are found, immediate return.

Hate that this is necessary, but consumers need to understand they are the quality control at this price.


So I faced the exact same problem today. Luckily I already had a software called as “Mini tool partition wizard” which I installed before for other purposes but it really helped me this time. Just google the name and you’ll find this small tool.

Just insert your disk

You will find your pen drive in the list. Now right click on the disk as shown and click on “Delete all partitions”.

After that, right click on the actual deleted partition,

Then click on “Create”. You don’t see the “Create” in this screenshot because I have already created it. But you’ll find it. Then you can add the name of the disk, the format, etc. click ok.

Finally, you need to click on “Apply” button that will appear at the bottom left.

That’s it, you are done. Now you can use your pen drive.

It should be noted all and any files a user may have on the drive will be gone with your approach.

1 Like

Not worked

It looks like your “Disk 3” says “Unformatted”, you need to right click and click “Format”. Then choose a filetype. You can either choose NTFS, FAT21 or exFAT (all the three are good for Windows). Then “Apply” the changes. I think it will start working.

Note that Formatting will delete everything from your drive.

I noticed that in your screenshot it says “Read Only”. There could be many reasons that happens. Maybe the hard drive is corrupt or there might be some kind of physical button that makes the drive read only (although that rarely happens in new drives). In most of the cases, I think formatting the disk should remove the “Read Only” problem.

No any options are showing after i right click on the disk whereas other drives showing properly