Sandisk Ultra USB 3.0 64GB - Can't Copy Files From It

I have a SanDisk Ultra USB 3.0 64GB jump drive. I have several files on it and I’m trying to remove the files so I can format the jump drive. I can copy one file at a time and It will let me copy files 6,000KB and smaller, but when I try to copy multiple files and files larger than 6,000KB it will freeze up. I can unplug it and plug it back in. It will then let me copy files again, but only if they are less than 6,000KB. It’s still within warranty, but I don’t want to lose my files. Is there anything I can do or do I just need to format it and see if the problem continues?

What is the format of the drive you are trying to copy the 6,000kb files to? The USB drive is formated as exFAT and can hold large files but your hard drive may be something else, maybe FAT32?

My hard drive isn’t the problem. I have tried to copy the files to several different computers. I’ve tried to copy the files to another SanDisk jump drive with no luck. I’ve deleted the files that I have gotten to copy, unplug the jump drive & plug it back in the next day and the files are still there. I have multiple SanDisk jump drives and this particular jump drive is the only one I have problems with. I’m almost ready to

What OS are you using? If you delete files and the next day they are still there if using Windows you are not Safely Removing the flash drive, the FAT/file allocation table is screwed up on it, if using Linux you have white files.

Or maybe the drive’s contacts are oxidized and need to be cleaned with emory paper.

Or maybe the drive is defective and needs to be replaced. Either to the seller or to SanDisk.