Unable to detect drive on HP Probook 6560b


Recently purchased the Extreme II (240Gb) and immediately tried to put it inside HP ProBook 6560b. Unfortunately, ssd cannot be recognised either in combo slot not in main hdd place. BIOS ver  f.42, AHCI mode. More interesting - when i inserted it into pretty old  acer 1830t - everything works like a charm. Advise needed - on how to deploy it on HP.




Chaged to SATA3 in BIOS. Now i see drive and of course the max speed cannot go over 260Mb fro read\write (as per ASSSD). Any ideas - issue related to HP BIOS or drive firmware in cinjunction with BIOS on thi sparticular notebook?

BTW tried to downgrade F.20 - no luck, speed as at SATA2. 

Some interesting thoughts: in hwinfo64 - chip rev B3, but on SATA AHCI controller shows B2, as per my undertsanding should be also B3… SATA AHCI controller claim speed support of gen3 6.0Gbps, but both ports 0 and 1 ports always in gen2 3.0Gbps mode despite any changes in BIOS…

Continue gaming with bios rev’s and settings, but pretty sure - there will be no success until HP bios update (or maybe HP + SanDisk FW) will be changed.

The disk itself is very good indeed…


BIOS F.40, SDD OCZ Vertex 3 60GB - BIOS detected drive when i set up 6GB sata option and W7 starts well, despite extreme II cannot, and visible only when 3GB sata option selected in BIOS…

So yes, again, HP have issue defenetely, until someone will prove otherwise (and frankly speaking i will be happy to see), but FW for extreme II also has some issues.

Maybe for someone my curiosity will save time, so i tried BIOSes F.20, 22, 27, 28, 40, 41, 42 in many variations with options inside BIOS :slight_smile: - and yes, again, no luck, so will wait …

Hi Roni, take a quick look at the HP forum below. Looks like it might need a firmware update. 


The chipset in this particular model is either some AMD, or QM77\HM76 - so no isssue with chipset SATA port, as declared in rev. B chipset on my model. So seems provided link will not help me in my case, but you are right in general, i need to wait at least HP Bios update, and probbaly, SanDisk FW update then. OR (if i will be so lucky) only some chnages in SDD’s FW will be enough ( but i personally have a strong doubts about it :slight_smile: )