Ultrabackup 64GB Corrupt U3 CD-ROM Partition

I have a 64GB Ultrabackup and I was backing up data to it using robocopy and my computer went to sleep and when I turned it back on I could not access the drive so i took it out and stuck it back in.  Now the U3_System partition is name “unknown” and when I click on it there is i/o error.  The main partition is unavailable because it was password protected.  How can I fix it.  I’ve tried the u3 installer and remover but both don’t detect the drive I assume because of the volume label missing on the u3 partition.  I don’t care if I lose the data I just spent a bunch of money on this and want to get it fixed.  Tech support was not helpful, the guy disconnected from my chat.

if the installer and uninstaller do not work it will likely have to be replaced. i would give support a call. 866-sandisk

that sucks because I can’t send it in with the content I have on it :-)  There’s no way to fix the partition? I’ve been searching around to rewrite the cd-rom volume.

the only way to rewrite the cd partition is with the u3 installer. so if that does not work it likely cant be fixed. there is a hacked version out there called u3 switch blade you can try but you may get similar results. you can let them know you have sensitive data on it and they will let you drill a hole through the memory chip. but you will still have to return it. 

ah that would be nice if I could do that, I will call and ask about sending back and drilling hole through the chip.  what type of warranty do these have?

5 year limited warranty

Man I haven’t had very good help from their support.  First support technician on chat just disconnected after telling me the drive was bad and offering no solution.  Now I call support and says 15 min hold and leave message so I did, still no call back.  Frustrating.

Hello barkster,

I was able to find your incident in our support system.  I have escalated the case to the support management team so they can look into why the chat was disconnected without completing the RMA. That being said the support agent actually sent you a follow up email asking for your shipping information so they could create the RMA for you.  You never replied to this message so support was unable to complete the RMA.  I also tested the support line and there is no wait time so feel free to contact support at 866-SANDISK and provide your email address and they will be able to pull your incident and complete the RMA process. 

Forum Admin

slotmonsta

Thanks for the help. I called back and they were very helpful and I was given permission to drill hole through it and rma to send it back.  That is a relief I thought I was going to have to eat $175 on that one.  I love all my u3 drives and have never had anything like this happen to one.