ULTRA PLUS 256GB FIRMWARE UPDATE PROBLEM

Hi,

I’m not new to firmware upgrades but I have been unable to update my 256GB Ultra Plus drive(s) with either of the current firmwares available - X2306RL or X2316RL.

I’m not getting anywhere near the advertised rated performance, currently the drives are showing firmware 10.03.00, I’ve noticed on a SSD user upload website that drives showing firmware 10.03.00 are showing nowhere near  the performance of the same model drive with firmwares X2306RL or X2316RL - this has also been confirmed on a different site , specialising in SSD RAID testing, where an upgrade to X2306RL showed large performance gains - both confirm my own opinion.

Currently setup in RAID 0 I have attempted to upgrade the firmware via both CD and USB on 3 different PC’s, using IDE / SATA /  AHCI / RAID options where available in each case.and on each system. I have also tried installing the drive to various connectors SATA1 SATA2 etc etc. with the above options.

Using the Sandisk software the program tells me that the update is available, and has been successful, in each case I have found that the firmware remains the same - 10.03.00. I have removed the cables from the drive after powering down each PC after the update attempts.The good news is that upon installing the drives back into the original PC the RAID set remains in place and I can boot to a system with no data loss. The only thing left to try is to break the current RAID configuration, format each drive and then attempt the firmware update on a number of PC’s that I have available. I don’t actually have a major issue with this, but it would be nice not to have go through this, only to find that the firmware update has again failed and I’ve now got to reinstall the O/S with no move forward.

Ideas anyone?

p.s.

In using the Sandisk software i too found that it would only allow me to download the X2306RL firmware I have tried this version, I have also manually downloaded version X2316RL and used the manual option in the software to install this to USB / CD.

BTW

If you have a RAID setup and are unable to confirm the exact model drive you have the Intel RST software is one of the few packages that will actually identify the drive model and serial number ina RAID set - the Sandisk software fails to do this on a RAID setup. (If you have an Intel chipset board I seriously suggest that you install the relevant RST software - it gives early notification of a problem drive and from my experience can be a life saver.)

UPDATE:

Further to my previous post:

I have received a reply from Sandisk Technical Support as I had already requested their assistance independent of my forum post.

Firmware 10.03.00 CANNOT BE UPGRADED.

“Based on the provided information we would like to inform you that the firmware version on your Solid State drives is a pre-version of the current firmware that has been released.  This particular firmware version is not upgradeable; this is why you have not been able to update it.”

To add insult to injury, after 4 hours of gaming on Saturday evening - both drives failed the following morning - my reply to Sandisk technical Support:

Hi Samantha and thank you for your swift reply.

 

Unfortunately, over the space of approximately 4 hours both drives failed on Sunday morning - please arrange to remove my personal details from the warranty registration as the retailer, or their supplier, will be returning the drives.

 

Whilst not part of your own remit please pass to whoever in the organisation that it refers too that in my opinion, to supply drives that operate at well below their advertised performance, that cannot be upgraded, will only ever result in a disgruntled customer – a customer that will not be purchasing Sandisk products in the near future.

 

I accept that all products can fail, particularly early on in the installation process, your site mentions a turnaround time of “between 3 – 4 weeks” for replacement, frankly, that is just completely unacceptable in this day and age, again, unhappy customers don’t come back.

 

Thank you for your personal service & support – about the only positive part of my experience with Sandisk.

 

That is just discracefull??! Like I said in my post I’m new to upgrading, will this ssd work? I want to clone my old drive onto. It cus I don’t have the windows cd, and but I see people saying about changing to ahci or something? When and how would I do that? Cheers

I am even more annoyed now as I had missed this reply post which would have saved me hours of frustration - Sandisk knowingly supplying drives which can not be upgraded, no support in the firmware updater which tells you as such and then your supposed to wait 3-4 weeks for a replacement product you just purchased - not that I was offered a replacement having mentioned 10.3.00 firmware in my email to Sandisk Support.

My suggestion:  return product to retailer and purchase a different manufacturers drive.

Re: Firmware update killed the drive?

‎07-09-2014 03:56 PM

Was the FW you had on the drive when you got it 10.03.00? If so there were a small number of drives manufactured with the wrong FW. Updating will cause the drive not to be detected after FW update. Contact SanDisk support and they will replace the SSD> 

**bleep** this yeah I’m gonna take it back to the retailer and get another not sandisk!