Sandisk Ultra + 256G firmware update failed twice


I bought a Sandisk Ultra+ SSD a few weeks ago and the first one I received had bad sectors; firmware update did not work, the disk was not even seen by the OS.

So I sent it back to the vendor ( with postal charges ) who sent me another disk.

I received the last one today and when I tried to update the firmware ( without doing anything before ), guess what… :

The update failed again ! You win !! ( but I lose :cry:)

I lost time, I lost money, and I lost my temper so I wrote you that message.

Please tell me this is a joke and that I won’t be forced to send again my disk to the vendor or to anyone else.

I have had many other disks since I work in computer science - ssd and hdd - but I never felt on such a situation.

I would be most gratefull if you would bring me a solution.

Many thanks in advance for your quick reply.


It is very rare to have 2 SSD in which the same issue occurs on one after another. I would try connecting the SSD to a different machine and see if the FW can be updated. If not I would contact sandisk support for warranty replacement. 

Thanks for the quick answer.

I have already tried with the first disk. I’m so disapointed that I have posted this message right after trying the ssd.

I will try again with the new one, I’ll keep you informed.

Thanks again.