Firmware update failed for SanDisk Ultra Plus 256Gb SSD using  SSD Toolkit

Received a SanDisk Ultra Plus 256g from today. Took it straight out of the box, and on advice from other forums, checked for firmware updates using SSD Toolkit Toolkit recommended firmware update.

Created a bootable USB Drive. Attached the SSD to a SATA port and booted to Firmware update… After running the update, the Updater reported “Firmware update of SanDisk SDSSDh2256g Failed”. 

Tried firmware update using a bootable CD created by Toolkit which resulted in the same failure.

The error output displayed on screen after the toolkit exited indicates the toolkit was unable to download the firmware update to the SSD drive.

The updater did not display version of available firmware update, only stated that an update was available. The toolkit detected firmware version X211200, which agrees with the current firmware version listed on this page:

Please advise whether the error indicates that the update is not applicable to the SSD model I purchased, or that the SDD is defective and must be replaced. Note that I have not formatted or initialized the SSD in any way, perhaps that’s the cause?

I have also reported this error to SanDisk customer support, and I will add Thier response to this thread.

you have the current far as i know there has not been a new release for Ultra + or it would be posted here. It may be showing an update is available by mistake. 

Hi, that was also the opinion of my coworker the hardware-guru. On that basis, I’m going to assume the disk is good and go ahead with it. Thanks again for your input!

Response from SanDisk Customer Support confirms:

Dear Philip,

Thank you for emailing SanDisk Technical Support. It is our goal to make sure you have all the resources you need to get the most from your product.

As I understand, you are having difficulties to update the firmware of your SanDisk Ultra Plus 256GB SSD. Please be advised the firmware of your SSD is already up to date - X211200, there are no new firmware updates released. Therefore, it is not required for you to update the firmware of your SSD.

Now the question ins, Why did the SSD Toolkit mislead me into attempting the firmware update in the first place? Was I at risk of damaging a otherwise perfectly good SSD?

SanDisk has officially released a new FW update for the Ultra+ SSD. Can you please try upgrading the FW again and let us know if you are still seeing an issue?

Foruma Admin


Hi Slotsmonsta,

Would you mind posting the date of release and expected revision number for the FW update? And do I still use the SSD Toolkit to burn the updater USB drive?

Never mind! I see there is an announcement in the top level of this topic.

Same toolkit, same ssd for me.
I created a bootable cd and same for me : Attached the SSD to a SATA port and booted to Firmware update… After running the update, the Updater reported “Firmware update of SanDisk SDSSDh2256g Failed”

Apparently, i have Firmware X211200. Still no new since ?
Apprently, there is X2306RL now but to download and apply it ?
On my side, i tested sandisk software available here

Is your SATA mode set to IDE? If so change the SATA mode to AHCI and update the FW then change it back to IDE before loading the OS. 

It’s installed on a dell inspiron 9400 which does not have AHCI.

Whatever, things are going worst, after the fail upgrade, i were able to reboot and continue to use the computer but once power off during quite some time and power on again. This time the computer does not detect the drive anymore (nor the sandisk utility of course).

I guess all my data are now lost (hopefully, i made a complete backup before trying firmware upgrade).

How to proceed to a RMA ?

Call sandisk support 866-sandisk

Im having the same problem. I just got it from and I cant update windows and when I check for firmware updates it says there is a update which is 2306RL…i think my firmware is version X231 at the moment. Can anyone help me out?

X2316RL is the latest FW. It does not seem it has been released to the update tool yet. YOu are running the latest FW so ignore any upgrade available message unless the FW version is higher than X2316RL

hi, I just yesterday purchased a sandisk ultra plus 256gb ssd I followed steps to update fw and it had No errors it said complete it rebooted my desktop then I cannot find the drive in windows even the toolkit thingy can’t find it? any help please?