Ultra Fit not working - is the 4th USB 3.0 pin normal?

Just got a new laptop and tried to copy some files from my Ultra Fit 32 GB (which has been working fine for several months now on different computers, despite getting a bit hot sometimes).

I plugged it in, after ~2 seconds the red LED turns on for about one second, then stops. There are 2 USB 3.0 ports and both do the same thing, every time I connect it.

Windows 10 does not recognize it AT ALL - not even on Disk Management, it doesn’t show up, nothing. The ports on this laptop are fine, I can use another USB key on them.

I tried looking for solutions, but found nothing specific. Then I tried looking at the internal part of the drive itself, and got surprised:

sandisk 4th pin.jpg

It’s a bit hard to get my flash to show it, but the 4th pin on the back (the one shining gold) is bent and touching the inner part of the enclosure! It seems to be pin 6, StdA_SSRX+ from what I found.

On the picture, you can (barely) see that all other pins are on what I assume are their “normal” position.

Now, I’ve never measured the speed of the drive, and my usual laptop is a Linux, so is it possible that it has always been this way (I can’t test it on another computer right now), and Linux just downgraded to USB 2? Is there a way to make Windows ignore such pins?

Overall, is it really abnormal that the pin is the way it is, and could that affect usage of the USB key?

I tried taking another picture just in case, but my mobile’s camera is not that good, and it needs a LOT of light (the pins are very far back in the enclosure).


It looks like the pin is definitely bent and it is not normal for the pin to touch the top of the USB port like that. I would suggest contacting sandisk support. They will most likely replace the drive for you.