Ultra 32 gb 50 m/sec cards problem

I have purchased 2  Ultra 32 GB 50 MB/s cards and both stop by themselves in my video recorder . I have used this exact same card previously and worked great but this latest batch just will not record . I tried numerous things , formatted the card before use , recorded until it stopped (the first card recorded 5 minutes of video , the second one 28 minutes , tried to download to computer but wouldn’t recognise it) tried my usual cards that have been using up until now - worked fine , retried the new cards and still the same . I contacted the support and got an Indian sounding guy , told him my problem (at least twice) , and told me he would have to hang up and will definitely call me back in 5 minutes , that was an hour ago . I have used Sandisk products for quite a number of years but it seems their quality control and support have disappeared . Not a happy customer and if you are on the lookout for a similar card , try another brand …save yourself the hassle of having the price of 2 cards go down the gurgler…as for their warranty service , forget it …Run away while you still can …lol

Hi, try this:

WARNING: This process eliminates the entire contents of the memory card, if you have information you should back up previously

Download the SD Card Formatter Sofware  link: https://www.sdcard.org/downloads/formatter_4/eula_windows/index.html

Disconnect all USB devices, now Connect the memory card with any usb card reader, then open the “sd card formatter” (Select the correct drive letter that corresponds to the memory card), click on “Option” and select “Format size Adjustment: ON”,  and proceeds formatting.

This should fix your problem

I gather from the speed that you have a CompactFlash, SD memory format utility working perfectly with your memory.