U3 failed to install, cant reformat USB now

Hi this happened to me a while ago but I was too lazy to register and ask for help but since it annoys me every time I use the USB more, I decided to ask for help. Sadly I dont know every detail about how it happened, its only vague but I hope you will be able to help me anyway:

So after I bought the USB I decided to remove the U3 software because it was really slow on my PC and barely working. The deinstallation went fine but when I got my new PC I decided to give the U3 software another try and wanted to install it (I was using the Windows 7 Beta at that time so maybe it was because of that).

In the middle of the installation he had a problem or the installation software quit for no reason, I dont know for sure now but fact is that he couldnt complete the installation and after taking a look on the device in the explorer I saw that he created 2 partitions, one for U3 and the other one for my files like he should.

But he didnt install the U3 software on the partition and I cant write to it because the partition is write-protected (as it should be). I tried it with the U3 deinstaller but he couldnt reverse the operation so I tried to format the whole device (both partitions).

The file partition worked but since the U3 partition is write-protected, I cant format it (and the Windows Message that appears every time I plug the USB in is very annoying (Windows cant read the disk, do you want to reformat it?)). Another thing that I have a space of like 20 MB that cant be used on a 512MB device and thats also annoying when you need every MB (and no Im not planning to buy a new one).

I also tried to reformat it with other programs and even under Linux but every time the message “cant format partition - it is write-protected” prevents me to do so.

So can I even delete that partition or is that not possible? And if it is possible, how do I do it?

“can I even delete that partition or is that not possible? And if it is possible, how do I do it?”

IMO  The only way to remove U3, and it’s associated CD drive, is to run the Uninstall U3 Launchpad option from the  U3 Launchpad Settings menu on the LAUNCHPAD window.  There use to be a separate utility you could download that would uninstall U3 but I don’t remember where it is.  Sorry.

Format Unformatable USB